Bug 2003937 - Finnish keymap selection does no need kbd-legacy with latest kbd
Summary: Finnish keymap selection does no need kbd-legacy with latest kbd
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-14 07:40 UTC by Marko Myllynen
Modified: 2022-02-11 11:23 UTC (History)
7 users (show)

Fixed In Version: anaconda-36.4-1, anaconda-35.22.2-2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-11 11:23:03 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Marko Myllynen 2021-09-14 07:40:41 UTC
Description of problem:
Finnish keymap selection required earlier kbd-legacy to work due to kbd:

https://bugzilla.redhat.com/show_bug.cgi?id=1955793

kbd has been now changed so that kbd-legacy is not needed for Finnish:

https://bugzilla.redhat.com/show_bug.cgi?id=2001787

This means that the anaconda change to add kbd-legacy for Finnish can now be reverted:

https://github.com/rhinstaller/anaconda/commit/b9c33400831024394e351753d7e413643f6a4757

Thanks.

Comment 1 Vendula Poncova 2021-09-20 10:27:14 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/3614

Thank you!

Comment 2 Adam Williamson 2021-09-25 00:04:00 UTC
Vendula, I think it would be good to fix this in F35 too. Can you push it to F35, or do you want an FE bug to do that?

Comment 3 Marko Myllynen 2021-09-28 09:49:41 UTC
I'm happy to confirm that installing Fedora Rawhide with anaconda-36.4-1 and kbd-2.4.0-7 things with Finnish keymap work as expected.

Having this (and the related kbd fix discussed in https://bugzilla.redhat.com/show_bug.cgi?id=2001787) would be indeed good to have in F35, too, yes. But we'd need both of these changes in F35 so I guess we'd need an FE bug or such for kbd as well?

Thanks.

Comment 4 Adam Williamson 2021-09-28 18:56:01 UTC
One FE bug could cover both updates. I thought you'd said the kbd change was done already, but looks like that's only for Rawhide, not F35.

Comment 5 Marko Myllynen 2021-10-06 08:42:18 UTC
We have now the updated kbd also in F35, see https://bugzilla.redhat.com/show_bug.cgi?id=2001787 and https://bodhi.fedoraproject.org/updates/FEDORA-2021-029b1ffb9a.

We could now go forward to have this change in F35, too.

Thanks.

Comment 6 Vendula Poncova 2021-10-07 11:41:23 UTC
Hi, it doesn't look like kbd asked for FE, so we don't have a bug we could use for a new F35 build.

Comment 7 Adam Williamson 2021-10-07 20:21:45 UTC
I re-opened https://bugzilla.redhat.com/show_bug.cgi?id=2001787 against F35 and proposed it as an FE issue. If you do a new anaconda build, I'll edit it into the kbd update, which is still in testing for now (it missed the freeze so didn't get pushed stable).

Comment 8 Ben Cotton 2022-02-08 21:37:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.


Note You need to log in before you can comment on or make changes to this bug.