Bug 200404 - firefox closes without any warning at some websites
firefox closes without any warning at some websites
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 10:39 EDT by Deepak Shrestha
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-28 07:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deepak Shrestha 2006-07-27 10:39:38 EDT
Description of problem:
firefox 1.5.0.4 for FC5 closes without any warning when trying to open the site
http://www.dluxproductions.com/webcandy/
This is not the case for other fedora releases where firefox 1.5.0.4 is
installed. Windows version can open this site without a problem too. Initially
thought its a plugin problem but all the necessary plugins are installed and yet
it craches at this particular site (may be others too).
Please check the fedora list for details
https://www.redhat.com/archives/fedora-list/2006-July/msg03579.html


Version-Release number of selected component (if applicable):
firefox 1.5.0.4

How reproducible:
Almost everybody who are using FC5 are getting the same results regardless of
their varieties of plugins.

Steps to Reproduce:
1. visit this site 
http://www.dluxproductions.com/webcandy/
2.
3.
  
Actual results:
firefox closes without any warning. If you "ps -A | firefox" to kill the
process, firefox starts from nowhere. 

Expected results:
firefox closes without any warning sign before loading the page. If you "ps -A |
firefox" expecting to get the process number of firefox, the browser appears
from nowhere.

Additional info:
Comment 1 Warren Togami 2006-07-27 10:47:00 EDT
What happens if you do this:
1) Close firefox completely.
2) 
export XLIB_SKIP_ARGB_VISUALS=1
firefox
3) Open that URL

Any difference?
Comment 2 Deepak Shrestha 2006-07-27 11:25:53 EDT
What happens if you do this:
1) Close firefox completely.
2)
export XLIB_SKIP_ARGB_VISUALS=1
firefox
3) Open that URL
=================


did same:
export XLIB_SKIP_ARGB_VISUALS=1
firefox

and opended that URL but the problem remains same (firefox closes unexpectedly).

Comment 3 Andre Robatino 2006-07-27 15:04:10 EDT
  I find that accessing the URL via an email link works.  However, any other
method I've tried (web page link, bookmark, copy and paste) reliably crashes the
browser.  It's definitely due to the flash plugin, since if I uninstall the
flash-plugin RPM, leaving all other plugins installed, I can access the page.
Comment 4 Andre Robatino 2006-07-27 15:06:44 EDT
  BTW, when you run 'ps -A | firefox', you're restarting the browser.  To get
the PID you want 'ps -A | grep firefox'.
Comment 5 Deepak Shrestha 2006-07-27 23:17:42 EDT
please check the fedora list link above. If its the flash related problem, why
some people with other versions of FC and firefox 1.5.0.4 with flash plugin were
able to access the same site without any problem? most of the post reported
crashed were FC5 users. I guess it may not be the problem in firefox itself but
something to do with FC5.
Comment 6 Andre Robatino 2006-07-27 23:27:08 EDT
  The first few people who responded said they could view the page.  After that,
everyone else said it crashed.  I think the first people to respond were
subscribed to fedora-list and were testing the link by clicking on the email
link, which would work.  The later people could have been reading the
fedora-list archive and been clicking on a web page link, or copying and pasting
the link, which would crash.  (I'm guessing, but it's a plausible theory.)  And
I think this problem has existed before FC5.  I will ask my father who still
uses FC4 to try the link and see if it crashes his browser.  Although FC4 is
still using an older version of Firefox, 1.0.8 I think.  Maybe the bug is
limited to the newer Firefox.
Comment 7 Deepak Shrestha 2006-07-28 01:18:02 EDT
I am also suscriber of fedora list and tried the email link to open in new
window, result is same.
Comment 8 Deepak Shrestha 2006-07-28 01:22:42 EDT
sorry for the "ps -A | firefox" where it should be "ps -A | grep firefox". My
mistake...
Comment 9 Deepak Shrestha 2006-07-28 03:07:08 EDT
By the way I thought its just the firefox problem. I tried with mozilla too and
came up with same result. I don't know if firefox and mozilla shares the same
engines or they use different ones.
Comment 10 Warren Togami 2006-07-28 05:12:00 EDT
If you are able to reproduce this consistently, then you should be able to get a
backtrace.  Install the matching firefox-debuginfo and get a complete backtrace
using gdb.  Attach it to this report.

My guess is that this is actually a crash in the Flash plugin, but we need a
backtrace to isolate the cause of the actual problem.
Comment 11 Deepak Shrestha 2006-07-28 07:06:07 EDT
I guess you are right. I removed the flash plugin and able to access the site.
so actually its not a bug at all. All the post convinced me that it must be a
bug. :-)

Tried it with mozilla and firefox both without flash and able to access these sites.

Note You need to log in before you can comment on or make changes to this bug.