Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2004081

Summary: cluster-etcd-operator: render command should fail if machineCidr contains reserved address
Product: OpenShift Container Platform Reporter: Sam Batschelet <sbatsche>
Component: EtcdAssignee: Haseeb Tariq <htariq>
Status: CLOSED WONTFIX QA Contact: ge liu <geliu>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: amulmule, htariq, tjungblu
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 2007448 (view as bug list) Environment:
Last Closed: 2022-08-24 17:14:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2007448    
Bug Blocks:    

Description Sam Batschelet 2021-09-14 13:32:54 UTC
Description of problem: OCP explicitly does not allow the use of the following reserved address blocks.

2001:db8::/32

192.0.2.0/24

If the render command observes these in the install-config as machineCidr it should fail and provide a clear message to admin.

https://github.com/openshift/cluster-kube-apiserver-operator/blob/d6a60b2c18806d69dcf27228aacb830a699126f3/pkg/operator/configobservation/etcdendpoints/observe_etcd_endpoints.go#L72



Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. create a cluster with machineCidr defined using one of the ranges above
2. cluster will fail to bootstrap because we will skip these endpoints in the observers used by the control-plane operators[1].
3.

Actual results: bootstrap fails for an unknown reason.


Expected results: bootstrap fails early as possible with a clear message indicating the address range is unsupported.


Additional info:

[1] https://github.com/openshift/cluster-kube-apiserver-operator/blob/d6a60b2c18806d69dcf27228aacb830a699126f3/pkg/operator/configobservation/etcdendpoints/observe_etcd_endpoints.go#L72

Comment 5 Scott Dodson 2022-08-24 17:14:20 UTC
With no customer cases attached and fixes having made it no further than 4.9 I'm going ahead and closing this as it's unlikely that we're on track to close this before 4.6 EOL.