Bug 20041 - Installation using Adaptec AHA29xx Card
Installation using Adaptec AHA29xx Card
Status: CLOSED DUPLICATE of bug 19328
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 11:43 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-30 11:43:47 EST
Adaptec driver won't load during installation. 

PC Contains

1 Adapted AHA29xx card with 1 Seagate Drive and 1 Cdrom Drive
EIDE controller 
           IDE1 - 4 Gig Drive - Contains Windows98
                3 Partitions, all Fat32
           IDE2 - 20 Gig Drive - Installation drive for Linux

Installations sees the two IDE drives but doesn't load the SCSI card 
driver. However it does detect that there is a SCSI card in the PC. Since 
the CDROM drive is on the scsi card, of course we can't install RH Linux 
7.0.
Comment 1 Hamlet Mun 2000-10-30 20:37:07 EST
I have installed RedHat 7.0 with these devices

Intel VC820 Motherboard with BIOS VC82010A.86A.0036.P16SCSI Adapter
Adaptec 2940U/UW (BIOS 2.57.2) (SCSI ID 7)
    at Bus:02h Device:09h / IRQ: 9 / IO Port: D800h
  Western Digital Vantage 9.1Gb U2W SCSI (SCSI ID 0)
  Saegate 4.5Gb UW SCSI (SCSI ID 1)

  UltraPlextor CD-ROM (SCSI ID 2)
  Yamaha 4260 CD ReWriter (SCSI ID 5)
  Iomega ZIP SCSI (SCSI ID 6)
Video Diamond Viper 770 OEM 16MB
Sound onboard
Network 3Com 3C509B

When I connect only UltraWide hard disks, the system works fine. But if I add 
UltraPlextor, Yamaha, Iomega (All connected with 58 pin cable), the system 
stops for 5 seconds every 2 minutes or less.

So I had to install & use linux without those devices using 58 pin cable.
The Windows 98 SE works good with & without those 58 pin devices mentioned 
above.
Comment 2 Michael Fulbright 2000-10-31 10:52:26 EST
If you look on virtual console 3 (use CNTL-ALT-F3 to switch) do you see any
information early in the install process about detecting your SCSI controller
and loading modules?
Comment 3 Hamlet Mun 2000-11-01 20:24:06 EST
I already installed RedHat system without devices using 50 pin cable.
But I can't use those devices even after installation.
When I boot the system with Yamaha, Plextor & Zip, the computer stops at:

"""Starting potmapper:                              """
"""SCSI host 0 abort (pid 1024) time out - resetting"""

When the SCSI card is resetting the cdrom light is blinking & this process 
repeats resetting every (I guess) minute forever ...

 I can't even use keyboard. Ctrl+Alt+Del doesn't answer!! I had to turn the 
computer off with the power swich.
 And after several tests, the gnome is not working any more. I'm using KDE. I'm 
getting more problems testing this module!!!
Comment 4 Brock Organ 2000-11-06 18:08:21 EST
hamletmun,

does removing the scsi hard drive from your chain (leaving only the scsi cdrom)
help ... (your timeouts make me think perhaps your drive is flaky!)
Comment 5 Hamlet Mun 2000-11-07 10:49:44 EST
All the devices working correctly with Windows 98 SE.
I don't think the problem could be harddisk.
At long last, Doug Ledford mailed me ^^ He said he's longer maintaining the 
aic7xxx driver & gave me this site "http://people.FreeBSD.org/~gibbs/linux/".

Someone can teach me how to do this stuff?
I tried to make new kernel but failed.

I'm getting this message when I do "make zImage"
These are last few lines...:

make[1]: Entering directory '/usr/src/linux/arch/i386/lib'
make all_targets
make[2]: Entering directory '/usr/src/linux/arch/i386/lib'
cc -D__KERNEL__ -I/usr/src/linux/include -D__ASSEMBLY__ -traditional -c 
checksum.S -o checksum.o
checksum.S:231: badly punctuated parameter list in #define
checksum.S:237: badly punctuated parameter list in #define
make [2]: *** [checksum.o] Error 1
make [2]: Leaving directory '.usr/src/linux/arch/i386/lib'
make [1]: *** [first_rule] Error 2
make [1]: Leaving directory '/usr/src/linux/arch/i386/lib'
make: *** [_dir_arch/i386/lib] Error 2
Comment 6 Brock Organ 2001-01-10 16:42:34 EST
I am reassigning this to the kernel component ... I hope someone in that group
can maybe help you further or point you in the right direction ... good luck!
Comment 7 Nick Erickson 2001-08-30 01:16:55 EDT
I ran into the same problem today upgrading kernel from 2.2.16-22smp to 2.2.19-
7.0.8smp.  My Adaptec AIC-7850 hangs at boot with repeating 

'SCSI host 1 channel 0 reset (PID 18) timed out - trying harder
(SCSI 1:0:0:0) device reset, message buffer in use.'

Comment 8 Alan Cox 2003-06-05 18:16:34 EDT

*** This bug has been marked as a duplicate of 19328 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:47:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.