Bug 2004128 - FTI in Rawhide: nodejs (nothing provides /usr/bin/pwsh)
Summary: FTI in Rawhide: nodejs (nothing provides /usr/bin/pwsh)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2005047
TreeView+ depends on / blocked
 
Reported: 2021-09-14 14:28 UTC by Ben Beasley
Modified: 2021-09-30 00:52 UTC (History)
6 users (show)

Fixed In Version: nodejs-16.10.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-30 00:52:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Ben Beasley 2021-09-14 14:28:43 UTC
Description of problem:

The latest nodejs in Rawhide/F36 does not install because nothing provides /usr/bin/pwsh.

Version-Release number of selected component (if applicable): 1:16.9.1-1.fc36


How reproducible:

Steps to Reproduce:
1. mock -r fedora-rawhide-${ARCH} --enablerepo=local -i nodejs

Actual results:

> DEBUG util.py:444:  Error: 
> DEBUG util.py:444:   Problem: package nodejs-devel-1:16.9.1-1.fc36.s390x requires nodejs(s390-64) = 1:16.9.1-1.fc36, but none of the providers can be installed
> DEBUG util.py:444:    - conflicting requests
> DEBUG util.py:444:    - nothing provides /usr/bin/pwsh needed by nodejs-1:16.9.1-1.fc36.s390x

Expected results:

Package installs uneventfully.

Additional info:

Comment 1 Fedora Update System 2021-09-14 20:41:07 UTC
FEDORA-2021-5ca1a838f5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

Comment 2 Fedora Update System 2021-09-14 20:41:10 UTC
FEDORA-2021-5ca1a838f5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

Comment 3 Ben Beasley 2021-09-14 22:30:08 UTC
Thanks for fixing this!

Comment 4 Fedora Update System 2021-09-16 16:59:59 UTC
FEDORA-2021-5ca1a838f5 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5ca1a838f5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Ben Beasley 2021-09-16 17:39:55 UTC
This bug has resurfaced in Rawhide with 16.9.1-3.fc36:

> DEBUG util.py:444:  Error: 
> DEBUG util.py:444:   Problem: package nodejs-devel-1:16.9.1-3.fc36.ppc64le requires nodejs(ppc-64) = 1:16.9.1-3.fc36, but none of the providers can be installed
> DEBUG util.py:444:    - conflicting requests
> DEBUG util.py:444:    - nothing provides /usr/bin/pwsh needed by nodejs-1:16.9.1-3.fc36.ppc64le

I think that’s the build that was merged in with the OpenSSL 3.0 side tag.

It looks like the latest commit, https://src.fedoraproject.org/rpms/nodejs/blob/01e00d5acc7066fb62c73511fcf4ab537f574001/f/nodejs.spec, has a changelog message about the fix, but the fix itself was lost.

Comment 6 Stephen Gallagher 2021-09-20 12:10:15 UTC
Rawhide should be fixed as of https://bodhi.fedoraproject.org/updates/FEDORA-2021-4fbe40b238

Comment 7 Ben Beasley 2021-09-20 14:12:47 UTC
Thanks again! Works for me.

Comment 8 Fedora Update System 2021-09-27 12:20:02 UTC
FEDORA-2021-5ca1a838f5 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ca1a838f5

Comment 9 Fedora Update System 2021-09-28 20:20:17 UTC
FEDORA-2021-4dd44521bf has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4dd44521bf

Comment 10 Fedora Update System 2021-09-29 02:11:12 UTC
FEDORA-2021-4dd44521bf has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4dd44521bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4dd44521bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-09-30 00:52:57 UTC
FEDORA-2021-4dd44521bf has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.