Bug 2004241 - ODF4.9+LSO4.8 installation via UI, StorageCluster move to error state
Summary: ODF4.9+LSO4.8 installation via UI, StorageCluster move to error state
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.9
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.9.z
Assignee: afrahman
QA Contact: Oded
URL:
Whiteboard:
Depends On: 2003651
Blocks: 2005051
TreeView+ depends on / blocked
 
Reported: 2021-09-14 18:53 UTC by OpenShift BugZilla Robot
Modified: 2021-11-01 13:44 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-01 13:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10069 0 None open [release-4.9] Bug 2004241: Storage class name not passed in CR 2021-09-14 18:53:42 UTC
Red Hat Product Errata RHBA-2021:4005 0 None None None 2021-11-01 13:44:47 UTC

Comment 5 Martin Bukatovic 2021-09-16 15:06:30 UTC
(In reply to Ben Parees from comment #4)
> not a blocker per:
> https://github.com/openshift/console/pull/10069#issuecomment-920390809

Could you explain this conclusion in more detail?

Comment 7 Martin Bukatovic 2021-09-16 15:54:21 UTC
I read that OCP team decided to not grant this regression a blocker status. Ok, let's track it as a regression for ODF via cloned bz 2005051.

Comment 13 Oded 2021-10-27 19:48:19 UTC
Bug Fixed, storage cluster moved to Ready state

SetUp:
Provider: Vmware
OCP Version: 4.9.0-0.nightly-2021-10-27-091730
ODF Version: 4.9.0-204.ci
LSO Version: 4.9.0-202110182323

Test procedure:
1.Install OCP:
OCP Version: 4.9.0-0.nightly-2021-10-27-091730

2.Install LSO:
LSO Version: 4.9.0-202110182323

3.Install ODF Operator:
ODF Version: 4.9.0-204.ci

4.Add disks to worker nodes via vcenter

5.Install storage system:

6.Get storagecluster status:
$ oc get storagecluster
NAME                 AGE    PHASE   EXTERNAL   CREATED AT             VERSION
ocs-storagecluster   5m5s   Ready              2021-10-27T18:54:28Z   4.9.0

7.Check ceph health
sh-4.4$ ceph health
HEALTH_OK

8.Check noobaa status:
#------------------#
#- Backing Stores -#
#------------------#

NAME                           TYPE            TARGET-BUCKET                                     PHASE   AGE      
noobaa-default-backing-store   s3-compatible   nb.1635361125465.apps.oviner3-lso.qe.rh-ocs.com   Ready   13m46s   

#------------------#
#- Bucket Classes -#
#------------------#

NAME                          PLACEMENT                                                        NAMESPACE-POLICY   PHASE   AGE      
noobaa-default-bucket-class   {"tiers":[{"backingStores":["noobaa-default-backing-store"]}]}   null               Ready   13m46s   


for more details:
https://docs.google.com/document/d/1BAHljbumTRW0Q9dLzJTfnpNfLS6Ken_L_dpQCQx5-_Q/edit

Comment 15 errata-xmlrpc 2021-11-01 13:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4005


Note You need to log in before you can comment on or make changes to this bug.