This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 200428 - Xorg developer recommends getting latest mesa CVS for performance issues
Xorg developer recommends getting latest mesa CVS for performance issues
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 13:07 EDT by Kevin DeKorte
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 17:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7654 None None None Never

  None (edit)
Description Kevin DeKorte 2006-07-27 13:07:09 EDT
Description of problem:
i915 drivers GL performance in rawhide is much lower than in FC5. After opening
a bug at freedesktop #7654. The developer suggested getting a newer snapshot of
the mesa-libGL driver. 

Version-Release number of selected component (if applicable):
mesa-libGL-6.5-19.fc6

How reproducible:
Unknown

Steps to Reproduce:
1.
2.
3.
  
Actual results:
In FC6 ppacer gives 10-12fps compaired to FC5 giving 40-50fps on the same
hardware. Between FC5 and FC6 the i810 driver was upgraded from 1.5 to 1.6 which
had some major changes which exposed some problems in the mesa-libGL libs. 

Expected results:
I would expect some performance changes due to new features and aiglx. But not
more than 50% drop in performance.

Additional info:
The latest mesa-libGL package that is provided has improved 3d support alot (no
longer flickers horribly) but there is still more work to be done
Comment 1 Kevin DeKorte 2006-08-21 10:38:44 EDT
New mesa code is a big improvement...
mesa-libGLU-devel-6.5-22.20060818cvs.fc6
mesa-libGLU-6.5-22.20060818cvs.fc6
mesa-libGL-devel-6.5-22.20060818cvs.fc6
mesa-libGL-6.5-22.20060818cvs.fc6

Allows ppracer to run around 18-22fps after install of new mesa. Performance is
still not at the same level at FC5, but definately better.

Also, on FC5, I was running metacity and no aiglx. And on FC6 I am running
compiz and aiglx so the comparisons are not exactly the same. I would expect the
machine running aiglx to be a bit slower. 
Comment 2 Adam Jackson 2006-09-20 17:52:29 EDT
Mesa 6.5.1 RCs have been in rawhide for a while now, closing.

Note You need to log in before you can comment on or make changes to this bug.