Bug 200437 - RFE: installation from additional repositories by default
RFE: installation from additional repositories by default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-07-27 13:29 EDT by Bill Nottingham
Modified: 2014-03-16 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-27 15:39:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-07-27 13:29:10 EDT
Usage case: Extras!

So, something like:

 " The following addtional repositories have been configured:

  [X] Fedora Extras 6
 "
in the same screen where you can configure additional repositories; the user can
uncheck Extras to only install from their disks.

This can be populated by moving over the repo files from fedora-release, and
checking what's enabled.
Comment 1 Jeremy Katz 2006-07-27 17:50:57 EDT
Long-term makes some sense... not really viable given what code we have today
Comment 2 Chris Lumens 2007-02-27 15:35:19 EST
Does this make sense anymore with the extras merge?  We probably don't want to
enable -source or -debuginfo repos automatically, which really only leaves updates.
Comment 3 Bill Nottingham 2007-02-27 15:37:48 EST
So, I'll note that this original bug was actually *solved*, despite Jeremy's
comment #1.

In the future, yeah, it means updates, which has its own implementation issue.
Comment 4 Jeremy Katz 2007-02-27 15:39:49 EST
I think I fixed it after the comment :)

At the same time, it's done as a hack with hard-coding URLs instead of using the
repo files.  But we can probably close this out as that's something to attack
another day, time and place...  And updates is covered by another bug now as well

Note You need to log in before you can comment on or make changes to this bug.