Bug 20046 - "connection refused" messages for X clients
"connection refused" messages for X clients
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 12:45 EST by Stephen Walton
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-27 22:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Walton 2000-10-30 12:45:06 EST
I know this is a little vague:  I installed RedHat 7.0 in my Dell Precision
Workstation 420.   I am the only non-root user on this system. 
Intermittently, usually after the system has been running for a while and
I've logged off and back on several times, messages about "connection
refused on display :0" begin to appear on the system console.  Often this
results in very weird things, like two overlapping copies of the icons on
my KDE desktop, apparently because kwm thinks it didn't run correctly the
first time and restarts itself.  (I've verified with ps that two copies of
kwm are running in these situations.)

When I'm logged in, "ps -efw | grep X" reveals that /etc/X11/X is running
with the -auth switch specifying a file in /etc/X11/xdm/authdir.  Comparing
with a 6.2 system without this problem and with mainly up-to-date patches,
I notice that /etc/X11/xdm/authdir is a real directory, mode 0600, owned by
root, while under 7.0 it is a symlink to /var/lib/xdm;  the latter is mode
0644 by default.  Otherwise (and I'm not an X guru) I can't offhand see
anything which would cause this.
Comment 1 Mike A. Harris 2001-06-19 01:23:10 EDT
Please attach an X server log from before and after this occurs.
Comment 2 Stephen Walton 2001-06-27 22:28:45 EDT
This was such a long time ago that I honestly don't remember how I fixed it, 
but it was probably an update.  In any event, the system in question is now 
running 7.1, so I can't really help with this problem any more.
Comment 3 Mike A. Harris 2001-10-31 22:35:07 EST
Ok thanks, closing bug.

Note You need to log in before you can comment on or make changes to this bug.