Bug 200474 - VNC viewer doesn't work with colour depth of 24 bpp
VNC viewer doesn't work with colour depth of 24 bpp
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-27 19:54 EDT by Craig McQueen
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 06:25:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs of vnc viewer and X.org on my laptop (7.99 KB, application/zip)
2006-10-30 02:51 EST, Craig McQueen
no flags Details

  None (edit)
Description Craig McQueen 2006-07-27 19:54:14 EDT
Description of problem:
I recently installed FC5 on both my desktop machine and my laptop (IBM Thinkpad
i1100). When I tried to access the desktop machine using vncviewer on my laptop,
I got the message "Couldn't find suitable pixmap format". I dug around on the
'net and eventually found a web site that basically said that VNC viewer doesn't
support 24 bpp. I'd just let FC5 install configure my laptop, and had chosen
800x600, "Millions of colours", with no further edits of xorg.conf. I guess the
laptop has some technical reason why it uses 24 bpp rather than 32 bpp. After
reading the web site, I changed the laptop to "Thousands of colours" and it
worked after that. But I want my millions of colours. :-)

The web site I found was:
http://www.karlrunge.com/x11vnc/

See also:
man page for xorg.conf, regarding "Bpp" option.

Version-Release number of selected component (if applicable):
Whatever the standard VNC RPM is for FC5

How reproducible:
Always

Actual results:
"Couldn't find suitable pixmap format." What a baffling error message. It didn't
really tell me that the problem was that VNCviewer doesn't support a colour
depth of 24 bpp. The web site mentioned says that TightVNC has a more meaningful
error message.

Expected results:
Works fine

Additional info:
Comment 1 Adam Tkac 2006-09-02 15:03:29 EDT
Are you sure that you REALLY NEED 24bpp?? I think adding support for 24bpp to
vncviewer and vncserver is quite needless, isn't it??
Comment 2 Craig McQueen 2006-09-05 22:56:41 EDT
Well I suppose I could go back to Windows...

As described in the initial bug report above, the installation on the laptop was
stock standard (no fiddling with the xorg.conf by hand or anything). I chose
"Millions of colors". I assume the goal is for non-technical users to not get
baffling error messages about pixmaps when they are installing and using Fedora
very standardly and typically.

I've investigated further and found that the Silicon Motion driver for X.org
appears to do a colour depth of 24 rather than 32. See 'man siliconmotion', near
the top, for details. So I assume for anyone using this driver, with "millions
of colors", they would currently get that baffling error message in VNC viewer.
Comment 3 Adam Tkac 2006-10-03 04:58:23 EDT
I went throught vnc source code and I've found interesting solution. It's only
one difference between 24bpp and 32bpp - 32 bpp has 8bit alpha canal. And
vncviewer and vncserver don't use this canal. In vnc could be 24bpp and 32 bpp
formats the same. So, if you're using 32bpp you're really using 24bpp.
Comment 4 Adam Tkac 2006-10-11 11:27:31 EDT
I'm going to close this bug because 24bpp and 32bpp are the same in vnc. But I'm
ready to reopen this bug if any problems occur.
Comment 5 Craig McQueen 2006-10-15 04:32:01 EDT
I think this should not be closed -- I think it _is_ a bug since the problem as
originally reported really does happen.
Comment 6 Adam Tkac 2006-10-17 09:31:57 EDT
please, try to reproduce with latest version of vnc. I tried reproduce this bug
with 4.1.2-3.fc6 (server and viewer).

my desktop machine: "milions of colours" 1024x768, vncserver
my laptop: "milions of colours" 800x600, vncviewer

laptop $ ssh -X desktop
$ vncviewer :0

And I can see my desktop's desktop...
Comment 7 Craig McQueen 2006-10-17 17:53:46 EDT
I'm currently running FC5 with vnc-4.1.1-39.fc5. The newer version RPM isn't
available for FC5. I've checked the release notes for 4.1.2 and all it says is
"fixed security vulnerability".

If you would like to try reproducing this bug, I suggest that on the laptop
machine, you try setting Option "Pixmap" "24" in your xorg.conf file. See the
Pixmap option in the man page for xorg.conf for more details.

As I said above, the siliconmotion driver always does 24 bpp rather than 32 bpp,
which is why I'm having this issue on my laptop.
Comment 8 Adam Tkac 2006-10-18 03:45:55 EDT
Yes, I've read siliconmotion man page. could you send me your vncserver and
vncviewer log, please??
Comment 9 Adam Tkac 2006-10-27 09:19:57 EDT
I did some tests and I think, problem is fixed now. Please, download version for
fc-6 and send me your result
Comment 10 Craig McQueen 2006-10-30 02:51:27 EST
Created attachment 139701 [details]
Logs of vnc viewer and X.org on my laptop
Comment 11 Craig McQueen 2006-10-30 02:56:09 EST
A sorry I'm a bit slow on the previous request for logs. They're attached in
case they're still of some use. Also I'll try the new version for FC6 soon.
Comment 12 Craig McQueen 2006-11-12 02:00:39 EST
I tried to install the latest FC6 version RPM, but I'm still running FC5, and it
was having trouble with missing dependencies.

Also what version do you mean exactly? I did find an RPM for FC6 for version
4.1.2-5 (which I couldn't install) but I think a change log I saw didn't mention
this issue.
Comment 13 Adam Tkac 2006-12-12 06:25:29 EST
I've open enhancement request on upstream. This isn't a bug because it is
known+documented that vncserver doesn't support 24bits-per-pixel depth. I don't
know if it could be implemented in next versions of vnc...

Note You need to log in before you can comment on or make changes to this bug.