Bug 2004953 - [vSphere] Incorrect user agent in vCenter sessions list
Summary: [vSphere] Incorrect user agent in vCenter sessions list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.10
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.z
Assignee: dmoiseev
QA Contact: Yihao Guo
URL:
Whiteboard:
Depends On: 2002262
Blocks: 2047844 2048496
TreeView+ depends on / blocked
 
Reported: 2021-09-16 13:44 UTC by OpenShift BugZilla Robot
Modified: 2022-01-31 11:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-01 13:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 918 0 None open [release-4.9] Bug 2004953: Fix user-agent in vCenter sessions list 2021-09-16 13:44:16 UTC
Red Hat Product Errata RHBA-2021:4005 0 None None None 2021-11-01 13:44:47 UTC

Description OpenShift BugZilla Robot 2021-09-16 13:44:05 UTC
+++ This bug was initially created as a clone of Bug #2002262 +++

Description of problem:
Currently user-agent record in vCenter session list does not allow to track MAPI related open sessions.

Version-Release number of selected component (if applicable):
4.5+, or whatever version where vsphere platform was introduced

How reproducible:
Always (?? checked on vCenter 7.0)

Steps to Reproduce:
1. Setup IPI cluster on vSphere platform
2. Check vsphere sessions list via, for example ```govc session.ls```. Or in vCenter web interface.

Actual results:
MAPI related session/s have `Go-http-client/1.1` user-agent.


Expected results:
User agent record should have some meaningful value, which allow to track sessions opened by vsphere-machine-controller.


Additional info:
there was an attempt to set this user-agent in vsphere controller, but it doesn't work: https://github.com/openshift/machine-api-operator/blob/aa3aa87654a3db7dd96feb4c157e744c4bcce986/pkg/controller/vsphere/session/session.go#L92

Comment 8 errata-xmlrpc 2021-11-01 13:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4005


Note You need to log in before you can comment on or make changes to this bug.