Bug 200503 - Package iptraf lacks IPv6 support.
Package iptraf lacks IPv6 support.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iptraf (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Zdenek Prikryl
bzcl34nup
:
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-07-28 04:18 EDT by Peter Vrabec
Modified: 2008-06-10 07:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 07:23:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-07-28 04:18:31 EDT
Description of problem:
It seems there might be some problem with IPv6 support in iptraf.
  
Actual results:
iptraf-3.0.0/src/revname.c:                               sizeof(struct in_addr), AF_INET);
iptraf-3.0.0/src/promisc.c:    ifd = socket(PF_INET, SOCK_DGRAM, 0);
iptraf-3.0.0/src/promisc.c:    fd = socket(PF_INET, SOCK_DGRAM, 0);
iptraf-3.0.0/src/rvnamed.c:                       sizeof(struct in_addr), AF_INET);
iptraf-3.0.0/src/ifaces.c:    fd = socket(PF_INET, SOCK_DGRAM, IPPROTO_UDP);

Expected results:
IPv6  compliant code.

Additional info:
http://people.redhat.com/drepper/userapi-ipv6.html
Comment 1 Marcela Mašláňová 2006-08-28 07:32:37 EDT
I look at it. It needs many changes in whole code.
Comment 2 Marcela Mašláňová 2006-09-05 03:16:42 EDT
Work in progress, could be in update 1.
Comment 5 Bug Zapper 2008-04-03 13:52:46 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Marcela Mašláňová 2008-04-04 06:36:08 EDT
This should be fixed once.
Comment 7 Bug Zapper 2008-05-13 22:15:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Zdenek Prikryl 2008-06-10 07:23:45 EDT
Because of many changes in the code, I do not backport this support into F9.

Note You need to log in before you can comment on or make changes to this bug.