Bug 200510 - FC5 not bootable (after installation) on RAID system
FC5 not bootable (after installation) on RAID system
Status: CLOSED DUPLICATE of bug 187193
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 06:04 EDT by PatrickM
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 15:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description PatrickM 2006-07-28 06:04:07 EDT
Description of problem:
After installation of FC5 on a Compaq system fitted with a Compaq Smart Array
431, the system comes to a halt during it's first boot with the following message:
----------------------------------------
Checking filesystems
fsck.ext3: Permission denied while trying to open /dev/ida!c0d0p2
You must have r/w access to the filesystem or be root
----------------------------------------
For your info: /dev/ida/c0d0p2 is a partion assigned as /
Why there is a ! in the path I can't explain.


Version-Release number of selected component (if applicable):
Fedora Core 5 + SELinux enabled (default enabled during installation)

How reproducible:
As long as SELinux is enabled, no way to get passed the problem.


Steps to solve it:
1. Booted the system with the first installation cd of CentOS4.3 (no SELinux!)
2. Manually edited /etc/fstab and set the checks to "0 0" on all /dev/ida/..
partitions
3. Reboot and the system will boot.
4. Disable SELinux and restore /etc/fstab.
5. System works without a flaw!
  

Additional info:
Although I did not test FC6t1, I expect SELinux to be enabled during
installation by default in the coming release(s).

Please, implement SELinux in FC6 in the same way as BEFORE FC5: disable SELinux
and ask the user during the configuration at the first boot to enable it.

After restoring /etc/fstab, I noticed not all /dev/ida/c0d0p1 - c0d0p7
partitions being displayed correctly. Although the system works, some are
displayed still displayed as /dev/ida!c0d0p2 (as in the original crash message),
but others are displayed as /dev/ida/c0d0pX
Comment 1 Daniel Walsh 2006-07-28 09:49:44 EDT
The problem here is that udev or something else is creating a badly
named/labeled file.  SELinux has no idea what this is so it ends up labeled
device_t instead of fixed_disk_device_t.  

Comment 2 Kay Sievers 2006-08-02 10:40:29 EDT
Udev replaces '!' with a '/' and creates a subdir. I don't think it's udev who
creates these nodes.
Comment 3 Daniel Walsh 2006-09-18 15:47:44 EDT

*** This bug has been marked as a duplicate of 187193 ***

Note You need to log in before you can comment on or make changes to this bug.