Bug 2005242 - kube-apiserver with "[SHOULD NOT HAPPEN] failed to update managedFields" err="failed to convert new object (machine.openshift.io/v1beta1, Kind=MachineHealthCheck)
Summary: kube-apiserver with "[SHOULD NOT HAPPEN] failed to update managedFields" err=...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.9.z
Assignee: Joel Speed
QA Contact: Huali Liu
URL:
Whiteboard:
Depends On: 1999425
Blocks: 2026562
TreeView+ depends on / blocked
 
Reported: 2021-09-17 08:18 UTC by Joel Speed
Modified: 2021-12-09 09:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1999425
: 2026562 (view as bug list)
Environment:
Last Closed: 2021-10-26 17:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 919 0 None open Bug 2005242: MaxUnhealthy should not be a string type 2021-09-17 08:19:06 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:22:57 UTC

Comment 4 Huali Liu 2021-10-19 06:01:42 UTC
reproduce this bug on 4.8.8-x86_64:

1.Vsphere 7 IPI installed cluster with windows_server_ver_2004 workers and OVNKubernetes network

2.Run this test case https://polarion.engineering.redhat.com/polarion/#/project/OSE/workitem?id=OCP-25691

3.Check the kube-apiserver logs on all master nodes.

liuhuali@Lius-MacBook-Pro openshift-test % oc logs kube-apiserver-huliu015-xssmx-master-0  -n openshift-kube-apiserver |grep "SHOULD NOT HAPPEN"     
Using deprecated annotation `kubectl.kubernetes.io/default-logs-container` in pod/kube-apiserver-huliu015-xssmx-master-0. Please use `kubectl.kubernetes.io/default-container` instead
E1019 02:45:38.810086      23 fieldmanager.go:191] "[SHOULD NOT HAPPEN] failed to update managedFields" err="failed to convert new object (machine.openshift.io/v1beta1, Kind=MachineHealthCheck) to smd typed: .spec.maxUnhealthy: expected string, got &value.valueUnstructured{Value:0}" VersionKind="machine.openshift.io/v1beta1, Kind=MachineHealthCheck"
liuhuali@Lius-MacBook-Pro openshift-test % 


verified on 4.9.0-0.nightly-2021-10-18-182325,

NO "[SHOULD NOT HAPPEN]" error was found again, the maxUnhealthy "type: string" has been removed from crd.

1.Vsphere 7 IPI installed cluster with windows_server_ver_2004 workers and OVNKubernetes network

2.Run this test case https://polarion.engineering.redhat.com/polarion/#/project/OSE/workitem?id=OCP-25691

3.Check the kube-apiserver logs on all master nodes.

liuhuali@Lius-MacBook-Pro openshift-test % oc logs kube-apiserver-huliu017-6z6wp-master-0  -n openshift-kube-apiserver|grep "SHOULD NOT HAPPEN"
Using deprecated annotation `kubectl.kubernetes.io/default-logs-container` in pod/kube-apiserver-huliu017-6z6wp-master-0. Please use `kubectl.kubernetes.io/default-container` instead
liuhuali@Lius-MacBook-Pro openshift-test % oc logs kube-apiserver-huliu017-6z6wp-master-1  -n openshift-kube-apiserver|grep "SHOULD NOT HAPPEN"
Using deprecated annotation `kubectl.kubernetes.io/default-logs-container` in pod/kube-apiserver-huliu017-6z6wp-master-1. Please use `kubectl.kubernetes.io/default-container` instead
liuhuali@Lius-MacBook-Pro openshift-test % oc logs kube-apiserver-huliu017-6z6wp-master-2  -n openshift-kube-apiserver|grep "SHOULD NOT HAPPEN"
Using deprecated annotation `kubectl.kubernetes.io/default-logs-container` in pod/kube-apiserver-huliu017-6z6wp-master-2. Please use `kubectl.kubernetes.io/default-container` instead
liuhuali@Lius-MacBook-Pro openshift-test % 

liuhuali@Lius-MacBook-Pro openshift-test % oc edit crd machinehealthchecks.machine.openshift.io
 80                 pattern: ^((100|[0-9]{1,2})%|[0-9]+)$
 81                 x-kubernetes-int-or-string: true
 82               nodeStartupTimeout:
 83                 default: 10m

Comment 7 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935


Note You need to log in before you can comment on or make changes to this bug.