Bug 2005265 - Backport upstream patch to avoid declaring Fedora rpms as "unsafe"
Summary: Backport upstream patch to avoid declaring Fedora rpms as "unsafe"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F35BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-09-17 09:42 UTC by Kalev Lember
Modified: 2021-10-07 21:41 UTC (History)
5 users (show)

Fixed In Version: gnome-software-41~rc-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-20 19:54:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
another warning (240.04 KB, image/png)
2021-10-07 12:42 UTC, Geraldo Simião
no flags Details
print of the warning (60.94 KB, image/png)
2021-10-07 12:43 UTC, Geraldo Simião
no flags Details

Description Kalev Lember 2021-09-17 09:42:10 UTC
See https://pagure.io/fedora-workstation/issue/244 for details. The Workstation WG would like to have https://bodhi.fedoraproject.org/updates/FEDORA-2021-34621917ba in F35 Beta to avoid declaring all Fedora rpm packages as "unsafe" in gnome-software UI.

Comment 1 Fedora Update System 2021-09-17 09:42:38 UTC
FEDORA-2021-34621917ba has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-34621917ba

Comment 2 Fedora Update System 2021-09-17 19:41:37 UTC
FEDORA-2021-34621917ba has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-34621917ba`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-34621917ba

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Adam Williamson 2021-09-17 22:15:20 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/459 , marking accepted.

Comment 4 Fedora Update System 2021-09-20 19:54:55 UTC
FEDORA-2021-34621917ba has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 5 Geraldo Simião 2021-09-23 21:51:37 UTC
tested Fedora-KDE-Live-x86_64-35_Beta-1.2.iso and that bug is fixed.

Comment 6 Geraldo Simião 2021-10-07 12:42:54 UTC
Created attachment 1830365 [details]
another warning

Is this related to this bug? or something else?

Comment 7 Geraldo Simião 2021-10-07 12:43:27 UTC
Created attachment 1830366 [details]
print of the warning

Comment 8 Milan Crha 2021-10-07 15:54:34 UTC
I do not think it's a bug. If I understand correctly, then the LibreOffice is from Flatpak/Flathub, right? The Flatpak apps define their permissions and some of them are not considered safe. I do not speak of the language you have the screenshots in , thus I do not know what precisely those "red" are.

Comment 9 Adam Williamson 2021-10-07 21:41:01 UTC
yeah. I *think* that's saying it has full filesystem access and it's an X11 app (not Wayland), though I'm willing to be wrong. :D Either way, it does seem to be correct, not a bug.


Note You need to log in before you can comment on or make changes to this bug.