Bug 200558 - Obsoletes processing should be arch-aware
Obsoletes processing should be arch-aware
Status: CLOSED DUPLICATE of bug 200643
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 13:24 EDT by Alexandre Oliva
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-29 13:17:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-07-28 13:24:10 EDT
Description of problem:
If you have a repo containing packages for say both i386 and x86_64, and one
package available for both arches obsoletes another package that is installed
for only one of the arches, then both versions get installed.

Version-Release number of selected component (if applicable):
yum-2.9.3-2
rpm-4.4.2-31

How reproducible:
Every time

Steps to Reproduce:
1.Install random package x.{x86_64,i386,noarch}, doesn't matter
2.Build package y.i386 and y.x86_64, with Obsoletes: x
3.Create a yum repository with the y packages
4.Run yum update

Actual results:
Yum will install both y packages.

Expected results:
It would be nicer if it installed a package for the same arch or, failing that
because there's no such obsoletion package, the package in the arch most
suitable for the local configuration (in the example case, x86_64).

Additional info:
Comment 1 Alexandre Oliva 2006-07-29 13:17:36 EDT

*** This bug has been marked as a duplicate of 200643 ***

Note You need to log in before you can comment on or make changes to this bug.