Bug 200579 - iksemel fails to build on developmen/x86_64
iksemel fails to build on developmen/x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: iksemel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 15:03 EDT by Jeffrey C. Ollie
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 18:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH fixing make check on 64 bit args (4.10 KB, patch)
2006-11-16 15:42 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Jeffrey C. Ollie 2006-07-28 15:03:43 EDT
Description of problem: iksemel fails to build on 

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. Build iksemel on devel/x86_64
2.
3.
  
Actual results:
Making check in test
make[1]: Entering directory `/builddir/build/BUILD/iksemel-1.2/test'
make  check-TESTS
make[2]: Entering directory `/builddir/build/BUILD/iksemel-1.2/test'
PASS: tst-ikstack
PASS: tst-iks
/bin/sh: line 4: 22955 Segmentation fault      ${dir}$tst
FAIL: tst-sax
PASS: tst-dom
PASS: tst-sha
PASS: tst-md5
PASS: tst-filter
PASS: tst-jid
===================
1 of 8 tests failed
===================
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/iksemel-1.2/test'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/iksemel-1.2/test'
make: *** [check-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.83551 (%check)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.83551 (%check)



Expected results:
Making check in test
make[1]: Entering directory `/builddir/build/BUILD/iksemel-1.2/test'
make  check-TESTS
make[2]: Entering directory `/builddir/build/BUILD/iksemel-1.2/test'
PASS: tst-ikstack
PASS: tst-iks
PASS: tst-sax
PASS: tst-dom
PASS: tst-sha
PASS: tst-md5
PASS: tst-filter
PASS: tst-jid
==================
All 8 tests passed
==================
make[2]: Leaving directory `/builddir/build/BUILD/iksemel-1.2/test'
make[1]: Leaving directory `/builddir/build/BUILD/iksemel-1.2/test'

Additional info:
Build logs at:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/13310-iksemel-1.2-5.fc6/
Comment 1 Hans de Goede 2006-11-16 15:42:13 EST
Created attachment 141412 [details]
PATCH fixing make check on 64 bit args

Hi,

Since I've been getting quite into fixing 64 bit bugs I've taken a quick look
at this, fixing it was easy. This patch fixes it, the problem was that 0 was
getting passed to a vararg function as NULL pointer, while that will work fine
on 32 bits args, it will fail on 64 bit as 0 == 32bits and NULL == 64bits
there.
Comment 2 Jeffrey C. Ollie 2006-11-16 18:09:24 EST
Thanks for the patch!  "make check" on PPC is still failing, but that's a
different issue...
Comment 3 Hans de Goede 2006-11-17 11:31:45 EST
p.s.

Don't forget to send this upstream, please.


Note You need to log in before you can comment on or make changes to this bug.