Bug 2005871 - Cannot create Network Attachment Definition through UI
Summary: Cannot create Network Attachment Definition through UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.8.z
Assignee: Aviv Turgeman
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 1987169
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-20 11:35 UTC by Petr Horáček
Modified: 2021-11-11 20:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-11 20:12:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10314 0 None open Bug 2005871: Cannot create Network Attachment Definition through UI 2021-10-25 14:09:03 UTC
Red Hat Product Errata RHBA-2021:4109 0 None None None 2021-11-11 20:12:25 UTC

Description Petr Horáček 2021-09-20 11:35:53 UTC
Description of problem:
The Create Network Attachment definition wizard is not allowing me to create a new network, complaining that OpenShift Virtualization is not installed, despite it is.

Version-Release number of selected component (if applicable):
OCP 4.8.9
OpenShift Virtualization 4.8.1

How reproducible:
Unknown


Steps to Reproduce:
1. Install OpenShift Virtualization to the default openshift-cnv namespace
2. Navigate to Network -> Network Attachment Definitions -> Create network attachment definition

Actual results:
The Create button is gray, raising:
> OpenShift Virtualization Operator or SR-IOV Network Operator needs to be installed on the cluster, in order to pick the Network Type.


Expected results:
I should be able to create a network.


Additional info:
I can provide access to my cluster if needed.

Comment 1 Guohua Ouyang 2021-09-20 12:49:21 UTC
Hi Kobi,
Maybe we need to backport bugfix 1987169 to 4.8.z?

Comment 2 Yaacov Zamir 2021-10-04 08:34:46 UTC
> Maybe we need to backport bugfix 1987169 to 4.8.z?

Guohua, make sense to me too, thanks !

Aviv hi, https://github.com/openshift/console/pull/9688 did not agree to auto backport

Can you look and do the backporting of 1987169 manually

Comment 6 Guohua Ouyang 2021-11-03 23:58:39 UTC
Reproduced on 4.8.15 and verified on upstream release-4.8

Comment 8 errata-xmlrpc 2021-11-11 20:12:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4109


Note You need to log in before you can comment on or make changes to this bug.