Bug 200622 - Firefox crashes
Firefox crashes
Status: CLOSED DUPLICATE of bug 200033
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-29 00:47 EDT by Zenon Panoussis
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 15:40:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2006-07-29 00:47:54 EDT
Description of problem:

The 1.5.0.5-0.el4.1 just pushed out crashes on any en.wikipedia.org article (but
not on the main page). Assuming that wikipedia does not contain malicious or
terribly bad code, this should not happen. The 1.5.0.5 from mozilla.com does not
crash. Java/script on/off makes no difference. No extensions installed. 

How reproducible:
Every time. 

Steps to Reproduce:
1. Visit en.wikipedia.org. 
2. Type "redhat" in the search box and hit "go".
Comment 1 Landon Curt Noll 2006-07-29 06:20:22 EDT
Firefox crashes with a similar exit code and error message as noted in bug
#200627  as noted in:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200627#c3

even though bug #200627 is related to firefox extensions.
Comment 2 Zenon Panoussis 2006-07-29 16:29:18 EDT
Confirming, any attempt to open the extensions menu causes firefox to crash too.
I wrote "no extensions" in the original report, but that's of course not true;
all the language packs that come with the package itself were installed there.

rm -rf /usr/lib/firefox-1.5.0.5/extensions/* makes it possible to open the
extensions menu without crashing, but firefox still crashes on wikipedia.

Then again, recompiling with
--- firefox-mozconfig.orig      2006-07-29 14:39:11.000000000 -0500
+++ firefox-mozconfig   2006-07-29 14:39:26.000000000 -0500
@@ -12,7 +12,7 @@
 ac_add_options --enable-default-toolkit=gtk2
 ac_add_options --disable-xprint
 ac_add_options --disable-strip
-ac_add_options --enable-pango
+ac_add_options --disable-pango
 ac_add_options --enable-canvas

fixes the problem. Firefox no longer crashes on wikipedia, nor on opening the
extensions menu with all the language packs intact.
Comment 3 Zenon Panoussis 2006-07-29 17:25:16 EDT
Bug #161576 may have to do with this and bug #139531 does.
Comment 4 Pawel Sadowski 2006-07-29 20:48:34 EDT
The same happens while logged in a Gmail account and e.g. try to compose new mail.
Comment 5 Adam Guthrie 2006-08-01 17:19:07 EDT
This is a problem with libfreetype. The bug has since been fixed and there is a
new RPM available with the patch in it. See this bug fix advisory for more
information: http://rhn.redhat.com/errata/RHBA-2006-0613.html.
Comment 6 Warren Togami 2007-01-10 15:40:46 EST

*** This bug has been marked as a duplicate of 200033 ***

Note You need to log in before you can comment on or make changes to this bug.