Bug 200625 - bad release tag
bad release tag
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: createrepo (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-29 03:25 EDT by Ralf Corsepius
Modified: 2014-01-21 17:54 EST (History)
0 users

See Also:
Fixed In Version: 0.4.10-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 09:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-07-29 03:25:43 EDT
Description of problem:
The release tag of the createrepo-0.4.4-0.1 rpm uses a leading "0".

It should be using a release tag starting with "1"

Formally, this violates the packaging naming guidelines:
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-5ea39bbc33cf351b41b51325ac3527eff4c58dac

Technically, this leading '0' disables users, who want to replace the FC5
createrepo with an upstream version from choosing "a guaranteed to be not
conflicting release-tag".

Background: Due to several bugs affecting me, I can avoid replacing the
createrepo-4.4.1-0.1 rpm with packages being build from createrepo's CVS.
Normally, I'd use *-0.4.6-0.<date>, to allow RH to replace this local version
with a nominal future update, which I'd assume to apply *-0.4.6-1*.

The tag you have chosen renders this consideration (which is the background of
the guidelines to require -1) void.


Version-Release number of selected component (if applicable):
createrepo-0.4.4-0.1
Comment 1 Seth Vidal 2007-07-30 09:00:48 EDT
this appears to no longer be the case in fc6 and f7. I'm going to close this out.

thanks

Note You need to log in before you can comment on or make changes to this bug.