Bug 200636 - "Anaconda" fails to boot graphical installer
"Anaconda" fails to boot graphical installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-29 08:27 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 07:29:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-07-29 08:27:31 EDT
Description of problem:
After booting from rawhide "boot.iso" as of 2007-07-28 and entering
the requested information for an "http" install, "stage2.img" gets
downloaded successfully. Hereafter, the installer correctly reports
the display type ("LG L1710B" analog) which is connected to the "VGA"
output of an "IBM ThinkPad T23". There is a short flicker on the
screen as if the "X" server was about to start, buth immediately the
screen goes black. The monitor light remains green though which means
that at least there is a signal. It is not possible to switch to a
virtual console to see what's going on but "ctrl-atl-bckspc" is still
able to trigger the reboot of the system.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.72-1

How reproducible:
Always

Steps to Reproduce:
1. Boot from corresponding "boot.iso" (2007-07-28).
2. Enter install details and proceed to downloading "stage2.img".
  
Actual results:
Screen goes black.

Expected results:
Graphical installer is launched successfully.

Additional info:
Adding additional boot parameters such as "noprobe", "skipddc"
combined with various resolutions from "640x480" etc. has
no effect.
Due to an installer regression, current "anaconda-11.1.0.73-1" does
not get to the point where the "X" server is started. Hence, I cannot
make any statement about that version.
Comment 1 Jeremy Katz 2006-07-31 10:56:18 EDT
This should be better in trees with .73
Comment 2 Joachim Frieben 2006-08-01 07:29:33 EDT
Right, works for me in "anaconda-11.1.0.74-1".
Comment 3 Milan Kerslager 2006-08-19 05:58:09 EDT
I see Anaconda (FC6test2) not trying to use VESA driver like in the past.
Anaconda prints out that X server started ok, but the server does not started
("no screens
found" at the very end of the log file).


Note You need to log in before you can comment on or make changes to this bug.