Bug 200651 - REGRESSION: iproute2-2.6.9-tc.patch breaks tc
REGRESSION: iproute2-2.6.9-tc.patch breaks tc
Status: CLOSED DUPLICATE of bug 154014
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iproute (Show other bugs)
4.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Radek Vokal
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-29 20:12 EDT by Rik van Riel
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-29 20:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2006-07-29 20:12:32 EDT
Expected results:

wshaper works like it used to

Additional info:

Strace reveals the following:

[pid  6261] open("/usr/lib/tc/f_u32.so", O_RDONLY) = -1 ENOENT (No such file or
directory)

Of course, that file DOES NOT EXIST.  It should try to open
/usr/lib/tc/q_netem.so instead.

I think one (or both) of the snprintf changes in iproute2-2.6.9-tc.patch are to
blame for tc trying to open a non-existing shared library.

This is a regression and needs to be be fixed before RHEL4 U4 goes out the door.
Comment 1 Rik van Riel 2006-07-29 20:15:25 EDT
Found the original bug that caused the iproute2-2.6.9-tc.patch patch to be
introduced.

*** This bug has been marked as a duplicate of 154014 ***

Note You need to log in before you can comment on or make changes to this bug.