Bug 200668 - SVK missing dependency on perl(SVN::Mirror)
SVK missing dependency on perl(SVN::Mirror)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-SVK (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Burrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 07:49 EDT by Sean E. Millichamp
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.08-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-17 20:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean E. Millichamp 2006-07-30 07:49:36 EDT
Description of problem:
I have been using SVK from CPAN for a while and in the process of building a new
machine I decided to try the new perl-SVK RPM.  It seems to be missing a
dependency on 'perl(SVN::Mirror)'.

After manually installing perl-SVN-Mirror it seems to pass all of the module
requirements, though I can't confirm that it is actually working since now I am
getting messages regarding unblessed references when running svk commands.  I'm
still looking into that, but they seem to be unrelated.

Thanks!
Comment 1 Sean E. Millichamp 2006-07-30 07:53:39 EDT
Okay, the 'unblessed references' messages seem only to occur when I was trying
to work with some old SVK repositories and working areas I already had checked
out.  When trying the commands from a new account that had never used svk before
everything seems to work just fine (after installing perl-SVN-Mirror, of
course).  I'll just clear my old svk stuff out and start fresh.
Comment 2 Ian Burrell 2006-09-17 20:40:26 EDT
I rebuilt the package and forgot to close the bug.  perl-SVK-1.08-5 requires
perl-SVN-Mirror.

Note You need to log in before you can comment on or make changes to this bug.