Bug 200674 - Anaconda Name rhxpl is not defined traceback
Anaconda Name rhxpl is not defined traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 11:51 EDT by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 10:38:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2006-07-30 11:51:26 EDT
Description of problem:
While using Kadischi, with Anaconda on a fully updated-from-development
repository host to build a LiveCD, Anaconda tracebacks with:
------------------
[kadischi] : running anaconda

Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 778, in ?
    xserver = rhpxl.xserver.XServer()
NameError: name 'rhpxl' is not defined
------------------



Version-Release number of selected component (if applicable):

anaconda-11.1.0.73-1
How reproducible:
Build a LiveCD with Kadischi and Anaconda on a Fedora Core 6 Test 1 host.

Steps to Reproduce:
1. kadischi --kickstart=/tmp/minimal-livecd.cfg
/var/ftp/pub/fedora/core/development/i386/os/ -f /tmp/FEDORA-RAWHIDE.ISO --extra
--headless
2. 
  
Actual results:
LiveCD build fails during Anaconda


Expected results:
LiveCD created successfully

Additional info:
This could simply be a import missing for rhxpl, it may not be.. I assume it is.
In any case, it halts progress with Kadischi and Anaconda for FC6T1(RAWHIDE).

Thanks.
Comment 1 Chris Lumens 2006-07-31 10:38:08 EDT
This looks like another case of needing the newer version of rhpxl available. 
anaconda now requires a newer version.

Note You need to log in before you can comment on or make changes to this bug.