Bug 200695 - firstboot shows an already created user
firstboot shows an already created user
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 21:56 EDT by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 17:15:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2006-07-30 21:56:47 EDT
Description of problem:
After using Anaconda kickstart, adding a user in %post with password, firstboot
create user dialog shows the created user already in it's dialog. I think this
shouldn't be happenning.
I see no reason firstboot would gather the name of the already-present user.
Is there anything specific why firstboot does this?
I will file this as a bug. 
Thanks.

Version-Release number of selected component (if applicable):
firstboot-1.4.6-1

How reproducible:
Use Anaconda's kickstart, then create a user in %post with useradd and usermod.
Firstboot create user dialog shows that user at boot time.

Steps to Reproduce:
1. Add a user in Anaconda's kickstart %post
2.
3.
  
Actual results:
Firstboot provides already created username in it's create user dialog.

Expected results:
Empty fields for new user account

Additional info:
There is no additional information at this time.
Comment 1 Chris Lumens 2006-07-31 09:44:01 EDT
What user is it showing, and what parameters are you using to create the new
user?  I've seen this before when certain packages create users sloppily, in
which case it's a packaging problem.  We might still be making an assumption
that's just not right in firstboot though.
Comment 2 Jasper O. Hartline 2006-07-31 15:05:25 EDT
Here is the entire %post section of the kickstart file:
-----
%post
useradd kadischi
# Default user password: kadischi
usermod -p '$1$gRE3sr6Y$2LKJsTzKnKumg2/noieRR1' kadischi
echo -e
"[security]\nDisallowTCP=false\n\n[daemon]\nAutomaticLoginEnable=true\nAutomaticLogin=kadischi\n\n[greeter]\n"
> /etc/gdm/custom.conf
-----

It does look a bit sloppy as you describe, with nothing more than a username
specified to useradd. I'll check out more lengthy options to useradd and report
any further success or failure.
Thanks.
Comment 3 Chris Lumens 2006-08-02 17:15:12 EDT
Since you're not specifying a UID for the new user, I think it defaults to 500.
 In firstboot's new user module, it automatically fills in the UI if it finds a
user with that UID.  Seems pretty goofy to me, so this is fixed in Rawhide now.

By the way, kickstart now supports adding users via the "user" command which we
added in time for FC6.

Note You need to log in before you can comment on or make changes to this bug.