Bug 200712 - repoquery deprecation warning with -C option
Summary: repoquery deprecation warning with -C option
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-31 09:24 UTC by Tim Jackson
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 11:34:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Jackson 2006-07-31 09:24:26 UTC
Description of problem:
Repoquery reports a deprecation warning when using the -C option.

Version-Release number of selected component (if applicable):
yum-utils-0.6-2.fc5
Repoquery version 0.0.11

How reproducible: Always

Steps to Reproduce:
1. repoquery -C perl

  
Actual results:
/usr/lib/python2.4/site-packages/yum/config.py:462: DeprecationWarning:
setConfigOption() will go away in a future version of Yum.
Please set option values as attributes or using setattr().
  DeprecationWarning)
Running from cache, results might be incomplete.
perl-4:5.8.8-5.i386

Expected results:
Running from cache, results might be incomplete.
perl-4:5.8.8-5.i386

Comment 1 Tim Jackson 2006-08-24 16:38:15 UTC
possibly related to https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=580

Comment 2 Tim Jackson 2006-11-04 23:45:46 UTC
This issue now completely breaks repoquery -c in FC6. (yum-utils-1.0.1-1.fc6)

$ repoquery -c something.conf foopackage
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 690, in ?
    main(sys.argv)
  File "/usr/bin/repoquery", line 652, in main
    repoq.conf.setattr('showdupesfromrepos', 1)
AttributeError: 'YumConf' object has no attribute 'setattr'

Comment 3 Tim Jackson 2006-11-04 23:55:23 UTC
I did of course mean "repoquery -C" not "repoquery -c"

Comment 4 Tim Jackson 2006-11-05 00:00:30 UTC
reported in the upstream bugtracker

https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=659


Comment 5 Panu Matilainen 2007-01-11 17:56:24 UTC
Fixed in yum-utils 1.0.x

Comment 6 Tim Jackson 2007-01-20 12:52:19 UTC
Any chance of an update to 1.0.2 in FE to close this bug?

Comment 7 Tim Lauridsen 2007-02-06 11:34:43 UTC
I have just pushed them to FE (FC6 & Devel), they will be available  at next push.



Note You need to log in before you can comment on or make changes to this bug.