Bug 200714 - paranthesis symbol in Source tag breakes rpm
paranthesis symbol in Source tag breakes rpm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 05:41 EDT by Andy Shevchenko
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-05 04:07:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Shevchenko 2006-07-31 05:41:06 EDT
Description of problem:
I should like to build my own rpm package from following source tarball:
ftp://202.65.194.18/cn/nic/rtl8111brtl8168b/linux-r1000(103).zip derived from 
http://www.realtek.com.tw/downloads/downloads1-3.aspx?Keyword=8168

But original name can't be used in rpm due to faults on decompress stage in 
section %setup.

Version-Release number of selected component (if applicable):
Last FC5 official build.

How reproducible:
Try to write simple specfile with given URL as Source0.

Expected results:
The given name is possible at least in the *nix file systems.
Comment 1 Jeff Johnson 2006-08-05 04:07:39 EDT
Adding parentheses in file names is asking for trouble, as the parentheses
will need escaping everywhere that the file is used in scripts.

Rename the tar ball when packaging, leaving a comment describing what was done:

E.g.
   # renamed from ftp://202.65.194.18/cn/nic/rtl8111brtl8168b/linux-r1000(103).zip
    Source0: linux-r1000_103.zip

Note You need to log in before you can comment on or make changes to this bug.