Bug 200716 - "Totem" package fails to rebuild because of obsolete BuildReq "mozilla-devel"
"Totem" package fails to rebuild because of obsolete BuildReq "mozilla-devel"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Monty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 05:49 EDT by Joachim Frieben
Modified: 2013-10-20 18:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 11:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-07-31 05:49:28 EDT
Description of problem:
The build of the "totem" package fails because the build requirements
include "mozilla-devel" whereas it should now require "firefox-devel".

Version-Release number of selected component (if applicable):
totem-1.5.4-3

How reproducible:
Always

Steps to Reproduce:
1. Execute "rpmbuild --rebuild totem-1.5.4-3.src.rpm".
  
Actual results:
Build fails complaing "mozilla-devel is needed by totem-1.5.4-3.i386".

Expected results:
Package should build cleanly.

Additional info:
After replacing "mozilla-devel" by "firefox-devel", the package
builds correctly only after adjusting the path to "nsIDOMWindow.h"
and to "nsIURI.h" in "totem-mozilla-plugin.cpp" because the
respective subdirectories are not in the actual include path.
Comment 1 Matthias Clasen 2006-07-31 11:45:44 EDT
Fixed

Note You need to log in before you can comment on or make changes to this bug.