Bug 200723 - fc-match "Thorndale AMT" -> "Nimbus Roman No9 L", not deja-vu
fc-match "Thorndale AMT" -> "Nimbus Roman No9 L", not deja-vu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dejavu-lgc-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 163147 (view as bug list)
Depends On:
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2006-07-31 07:20 EDT by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.95-10.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-12 10:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible patch (1.20 KB, patch)
2006-07-31 08:12 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Caolan McNamara 2006-07-31 07:20:44 EDT
on install of dejavu-lgc-fonts

fc-match "Thorndale AMT" now says...

DejaVuLGCSerif.ttf: "DejaVu LGC Serif" "Book"

instead of "Nimbus Roman No9 L"

Thorndale AMT is our RHEL "Times New Roman" metrically equivalent font.

So on RHEL fc-match "Times New Roman" when the agfa monotype fonts are installed
should say "Thorndale AMT", so that .docs opened in e.g. OOo look as close to
msword as possible. That's still ok.

On FC, fc-match "Times New Roman" should say "Nimbus Roman No9 L", that's still ok.

But On FC, fc-match "Thorndale AMT" should follow the "Times New Roman" logic
and give us "Nimbus Roman No9 L", so that stuff created in RHEL looks close to
correct on non-agfa installs, but with dejavu-lgc installed gives one of the
deja-vu fonts instead.
Comment 1 Caolan McNamara 2006-07-31 08:12:40 EDT
Created attachment 133312 [details]
possible patch

I'm not fontconfig config literate, but this patch to fontconfig's fonts.conf
does  what I want, explicitly set Nimbus No 9 Roman L as the preferred
Thorndale AMT fallback, and while I'm at it set the "upstream" afga monotypes
names as shipped as Staroffice as aliases to their "AMT" extension names as
shipped in RHEL. i.e. fix my problem :-) and make documents written in
StarOffice look right when opened with OpenOffice.org in RHEL/FC
Comment 2 Ray Strode [halfline] 2006-08-10 21:44:59 EDT
Behdad, does the patch look okay?
Comment 3 Behdad Esfahbod 2006-08-10 22:54:43 EDT
Yes, looks okay.  I'll push it in later, but feel free to do.
Comment 4 Caolan McNamara 2006-08-12 10:04:26 EDT
seen in fontconfig-2.3.95-10.fc6
Comment 5 Caolan McNamara 2006-08-12 10:05:49 EDT
*** Bug 163147 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.