This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 200727 - [PATCH] [si_LK] Firefox lacks of surrounding text support
[PATCH] [si_LK] Firefox lacks of surrounding text support
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 08:21 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (24.34 KB, patch)
2006-08-24 12:51 EDT, Akira TAGOH
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 353776 None None None Never

  None (edit)
Description A S Alam 2006-07-31 08:21:27 EDT
Description of problem:
when try to input for Sinhala Language, then failed to render properly

Version-Release number of selected component (if applicable):
firefox-1.5.0.5-7

How reproducible:


Steps to Reproduce:
1. Open  firefox
2. goto Address bar (any text input area)
3. for input,
please install scim-sinhala (from rawhide) and press following keys

4) "kRoo"
Ctrl+Space to activative and Deactivate Input method

  
Actual results:
rendering is broken

Expected results:
Rendering should like Gedit

Additional info:
test same input for gedit (ක්‍රෝ)
Font package: font-sinhala
Comment 1 A S Alam 2006-07-31 08:58:53 EDT
Adding si_LK Language Expert for More deep information
Comment 2 Matthew Barnes 2006-07-31 09:33:06 EDT
Changing component to firefox, reassigning.
Comment 3 Caolan McNamara 2006-08-01 10:29:53 EDT
Probably it's the same problem as OOo, so need to implement retrieve_surrounding
signal and delete_surrouding in the IMM, i.e. copying and pasting the text from
gedit works, so it's able to render the final text, but it's not able to give
feedback to the scim module about what text should be generated in relation to
the existing context.
Comment 4 Akira TAGOH 2006-08-21 00:53:18 EDT
I'll look into this issue.
Comment 5 Akira TAGOH 2006-08-24 12:51:30 EDT
Created attachment 134831 [details]
proposed patch

Attached patch is enabling the surrounding text signals on GTK+ that
scim-sinhala requires to get it work.
Comment 6 Matthias Clasen 2006-09-15 15:16:39 EDT
Please file an upstream bug at bugzilla.mozilla.org.

Given the "must be upstream first" policy for mozilla patches, these bugs can't
block FC6
Comment 7 Matthias Clasen 2006-09-21 14:49:20 EDT
Akira, can you file an upstream bug ?
Comment 8 Akira TAGOH 2006-09-22 03:55:18 EDT
Sure. filed.
Comment 9 Danishka Navin 2007-11-21 04:40:44 EST
kRoo  =  ක්‍රෝ

 its working on RHEL 5.1

Danishka Navin
LM - Sinhala
Comment 10 Matěj Cepl 2007-12-20 11:47:46 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.