Bug 2007294 - bootctl doesn't install entries
Summary: bootctl doesn't install entries
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: systemd
Version: CentOS Stream
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-23 14:10 UTC by Sergey
Modified: 2021-10-18 12:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-18 12:21:00 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-100125 0 None None None 2021-10-18 12:22:14 UTC

Description Sergey 2021-09-23 14:10:39 UTC
Description of problem:
"bootctl install --path=/boot/efi" doesn't create configs in /boot/efi/loader/entries/.
After that machine can't boot.

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. # bootctl install --path=/boot/efi
2. # ls -l /boot/efi/loader/entries

Actual results:
# ls -l /boot/efi/loader/entries
total 0


Expected results:
configs for installed kernels

Comment 1 Lukáš Nykrýn 2021-10-18 12:21:00 UTC
In rhel8 we do not support systemd-boot since grub2 is the preferred bootloader. Unfortunately, we do not plan to spend any time on this.


Note You need to log in before you can comment on or make changes to this bug.