Bug 2007325 - vips-8.12.2 is available
Summary: vips-8.12.2 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vips
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Goode
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-23 15:01 UTC by Upstream Release Monitoring
Modified: 2022-05-07 04:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-11 01:11:36 UTC
Type: ---


Attachments (Terms of Use)
[patch] Update to 8.11.4 (#2007325) (909 bytes, patch)
2021-09-23 15:01 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 8.12.0 (#2007325) (912 bytes, patch)
2021-11-20 18:30 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 8.12.1 (#2007325) (895 bytes, patch)
2021-11-25 07:46 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2021-09-23 15:01:34 UTC
Latest upstream release: 8.11.4
Current version/release in rawhide: 8.11.3-4.fc36
URL: https://libvips.github.io/libvips/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/5097/

Comment 1 Upstream Release Monitoring 2021-09-23 15:01:42 UTC
Created attachment 1825681 [details]
[patch] Update to 8.11.4 (#2007325)

Comment 2 Upstream Release Monitoring 2021-09-23 15:16:49 UTC
the-new-hotness/release-monitoring.org's scratch build of vips-8.11.4-1.fc32.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=76170243

Comment 3 Upstream Release Monitoring 2021-11-15 15:31:43 UTC
Latest upstream release: 8.12.0-rc1
Current version/release in rawhide: 8.11.3-6.fc36
URL: https://libvips.github.io/libvips/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/5097/

Comment 4 Upstream Release Monitoring 2021-11-15 15:31:46 UTC
Skipping the scratch build because an SRPM could not be built: ['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-jep27yg3/vips.spec'] returned 1: b'error: Bad source: ./vips-8.12.0.tar.gz: No such file or directory\n'

Comment 5 Upstream Release Monitoring 2021-11-20 18:30:31 UTC
Latest upstream release: 8.12.0
Current version/release in rawhide: 8.11.3-6.fc36
URL: https://libvips.github.io/libvips/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/5097/

Comment 6 Upstream Release Monitoring 2021-11-20 18:30:37 UTC
Created attachment 1842842 [details]
[patch] Update to 8.12.0 (#2007325)

Comment 7 Upstream Release Monitoring 2021-11-20 18:44:36 UTC
the-new-hotness/release-monitoring.org's scratch build of vips-8.12.0-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=79106738

Comment 8 Remi Collet 2021-11-22 07:42:05 UTC
See https://src.fedoraproject.org/rpms/vips/pull-request/4

This PR also 
- add the jxl (JPEG-XL) module
- use the new libcgif library for faster gif save
- fix the doc buid

Comment 9 Upstream Release Monitoring 2021-11-25 07:46:32 UTC
Latest upstream release: 8.12.1
Current version/release in rawhide: 8.11.3-6.fc36
URL: https://libvips.github.io/libvips/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/5097/

Comment 10 Upstream Release Monitoring 2021-11-25 07:46:38 UTC
Created attachment 1843524 [details]
[patch] Update to 8.12.1 (#2007325)

Comment 11 Upstream Release Monitoring 2021-11-25 07:58:34 UTC
the-new-hotness/release-monitoring.org's scratch build of vips-8.12.1-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=79251092

Comment 12 Upstream Release Monitoring 2022-01-19 08:38:53 UTC
Latest upstream release: 8.13.0-pre1
Current version/release in rawhide: 8.11.3-7.fc36
URL: https://libvips.github.io/libvips/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5097/

Comment 13 Upstream Release Monitoring 2022-01-19 08:38:56 UTC
Scratch build failed. Details bellow:

BuilderException: Build started, but failure happened during post build operations:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-a5za2uhx/vips.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./vips-8.13.0.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 14 Fedora Update System 2022-04-11 01:17:22 UTC
FEDORA-2022-a032eb48de has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a032eb48de

Comment 15 Fedora Update System 2022-04-11 14:57:29 UTC
FEDORA-2022-a032eb48de has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-a032eb48de`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a032eb48de

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2022-05-07 04:21:51 UTC
FEDORA-2022-a032eb48de has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.