Bug 200737 - broken libresolv.so.2 in glibc 2.3.6-3
broken libresolv.so.2 in glibc 2.3.6-3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 09:36 EDT by Klaas Gadeyne
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-02 13:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace report of wget failing with glibc 2.3.6-3 (16.14 KB, text/plain)
2006-08-03 03:29 EDT, Klaas Gadeyne
no flags Details
strace of working wget (glibc version 2.3.5-10) (28.10 KB, text/plain)
2006-08-03 03:31 EDT, Klaas Gadeyne
no flags Details

  None (edit)
Description Klaas Gadeyne 2006-07-31 09:36:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060406 Firefox/1.5.0.4 (Debian-1.5.dfsg+1.5.0.4-1)

Description of problem:
After upgrading from glibc-2.3.5-10 to glibc-2.3.6-3, programs using /lib/libresolv.so.2 for name lookups fail.  E.g.

root@server01:/var/cache/yum #
  wget http://www.dilbert.com/comics/dilbert/archive/images/dilbert21046980060731.gif
--14:23:01--  http://www.dilbert.com/comics/dilbert/archive/images/dilbert21046980060731.gif
           => `dilbert21046980060731.gif'
Resolving www.dilbert.com... failed: No such file or directory.

Downgrading the packages to the old version solves the problems.

Version-Release number of selected component (if applicable):
glibc-2.3.6-3

How reproducible:
Always


Steps to Reproduce:
1. Upgrade to new glibc packages
2. Use a program that uses libresolv.so.2


Actual Results:
All programs using libresolv.so.2 performing a name lookup fail (links, wget, ...).  Others not using the library (such as nslookup, firefox, telnet, ...) are unaffected.  Even yum fails!


Expected Results:


Additional info:
I've put the severity to high, since it prevented me from using yum do perform any further upgrades
Comment 1 Ulrich Drepper 2006-08-02 13:02:04 EDT
I'm closing this one.  If there would be such a problem we'd have heard more
about this than just one report.  Beside, the fc4 code is old.  If there are
still problems with the current code, reopen with more details like strace
output of a problem etc.
Comment 2 Klaas Gadeyne 2006-08-03 03:29:43 EDT
Created attachment 133536 [details]
strace report of wget failing with glibc 2.3.6-3
Comment 3 Klaas Gadeyne 2006-08-03 03:31:57 EDT
Created attachment 133537 [details]
strace of working wget (glibc version 2.3.5-10)

Apparently bugzilla only allows one attach for each comment...

Note You need to log in before you can comment on or make changes to this bug.