Bug 200755 - anaconda dies with: AttributeError: XSetup instance has no attribute 'xhwstate'
anaconda dies with: AttributeError: XSetup instance has no attribute 'xhwstate'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-31 10:46 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 12:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-07-31 10:46:12 EDT
Description of problem:
This was seen doing a kickstart install on my HP Integrity servers.  I do not
see this when I do an interactive install.  I am using serial console.  The
systems do have video hardware however I have not monitor/keyboard on any so
they are used as headless systems.

The screen was rather garbled but I think I have managed to make this somewhat
readable:



Traceback (most recent call last):
File "/usr/bin/anaconda", line 900, in ?  instClass.setInstallData(anaconda)
File "/usr/lib/anaconda/kickstart.py", line 889, in setInstallData
File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", line 1112, in
readKickstart self.handleCommand(lineno, args)
File "/usr/lib/anaconda/kickstart.py", line 766, in handleCommand
                       self.handler.handlers[cmd](self.id, cmdArgs)
File "/usr/lib/anaconda/kickstart.py", line 646, in doXConfig
                                                      dict["startX"])
File "/usr/lib/anaconda/installclass.py", line 408, in configureX
                                                           
self.setVideoCard(id, driver, videoRam)
File "/usr/lib/anaconda/installclass.py", line 404, in setVideoCard
            id.xsetup.xhwstate.set_videocard_ram(int(videoRam))
AttributeError: XSetup instance has no attribute 'xhwstate'
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
/mnt/runtime done
disabling /dev/loop0
/proc/bus/usb done
/proc done
/dev/pts done
/sys done
/tmp/ramfs done
/mnt/source done
you may safely reboot your system


Version-Release number of selected component (if applicable):
rawhide-20060731
anaconda-11.1.0.73-1

How reproducible:
100% when doing kickstart installs

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2006-07-31 12:54:40 EDT
Ah, this is just because of some odds and ends that didn't get finished up last
thing on Friday.  The whole new X startup process could still use some testing
on less common setups (headless, especially) since I don't have access to them.

Note You need to log in before you can comment on or make changes to this bug.