Bug 2007602 - gedit crashes when searching for files
Summary: gedit crashes when searching for files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gedit
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F35FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2021-09-24 11:17 UTC by sumantro
Modified: 2021-09-30 00:53 UTC (History)
12 users (show)

Fixed In Version: gedit-41~alpha-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-30 00:53:05 UTC
Type: Bug


Attachments (Terms of Use)
Logged crash report (49.86 KB, text/plain)
2021-09-24 12:30 UTC, sumantro
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gedit - issues 465 0 None None None 2021-09-27 18:33:29 UTC

Description sumantro 2021-09-24 11:17:43 UTC
Description of problem:

Gedit crashes with "gedit killed by SIGSEGV" on Beta 1.2 image when searching for a file name


Version-Release number of selected component (if applicable): gedit-41~alpha-1.fc35.x86_64


How reproducible: Always


Steps to Reproduce:
1. Open gedit 
2. Click the Open button on the left top corner
3. Type 2-3 chars

Actual results:

gedit crashes while searching for the file


Expected results:

Gedit should search for the file


Additional info:

Comment 1 Fedora Blocker Bugs Application 2021-09-24 11:20:21 UTC
Proposed as a Blocker for 35-final by Fedora user sumantrom using the blocker tracking app because:

 https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria#Default_application_functionality

Comment 2 sumantro 2021-09-24 12:30:56 UTC
Created attachment 1825888 [details]
Logged crash report

Comment 3 František Zatloukal 2021-09-27 09:32:12 UTC
So, initially, I wasn't able to reproduce this, with gedit-41~alpha-1.fc35.x86_64 (and basically stuff from updates-testing).

I had one text file, gedit search was working fine. 

Then, I've created a second text file, search started to crash and continued to keep crashing even after trying after removing the second text file leaving there only one text file in my homedir.

Comment 4 sumantro 2021-09-27 09:40:57 UTC
(In reply to František Zatloukal from comment #3)
> So, initially, I wasn't able to reproduce this, with
> gedit-41~alpha-1.fc35.x86_64 (and basically stuff from updates-testing).
> 
> I had one text file, gedit search was working fine. 
> 
> Then, I've created a second text file, search started to crash and continued
> to keep crashing even after trying after removing the second text file
> leaving there only one text file in my homedir.

yep can replicate this as well.

Comment 5 Adam Williamson 2021-09-27 16:07:38 UTC
+5 in https://pagure.io/fedora-qa/blocker-review/issue/479 , marking accepted.

Comment 6 Olivier Lemasle 2021-09-27 18:30:34 UTC
FYI, I've already reported this bug upstream: https://gitlab.gnome.org/GNOME/gedit/-/issues/465

Comment 7 Fedora Update System 2021-09-27 19:31:11 UTC
FEDORA-2021-e470b40e36 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-e470b40e36

Comment 8 Fedora Update System 2021-09-29 02:11:53 UTC
FEDORA-2021-e470b40e36 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-e470b40e36`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-e470b40e36

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 sumantro 2021-09-29 07:29:34 UTC
Fix works as intended

Comment 10 Fedora Update System 2021-09-30 00:53:05 UTC
FEDORA-2021-e470b40e36 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.