Bug 200774 - crash loading planet.gnome.org
Summary: crash loading planet.gnome.org
Status: CLOSED DUPLICATE of bug 200033
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-07-31 15:55 UTC by jmccann
Modified: 2015-01-14 23:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 17:00:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jmccann 2006-07-31 15:55:24 UTC
firefox-1.5.0.5-0.el4.1

Crashed trying to load planet.gnome.org just now.

When I run with --debug:

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread -1208166720 (LWP 11006)]
0x004b601a in FT_Realloc () from /usr/lib/libfreetype.so.6
(gdb) bt
#0  0x004b601a in FT_Realloc () from /usr/lib/libfreetype.so.6
#1  0x0051d29c in TT_GDEF_Get_Glyph_Property ()
   from /usr/lib/libpangoft2-1.0.so.0
#2  0x0051d3e7 in TT_GDEF_Build_ClassDefinition ()
   from /usr/lib/libpangoft2-1.0.so.0
#3  0x00530437 in pango_ot_info_get_gdef () from /usr/lib/libpangoft2-1.0.so.0
#4  0x0053052c in pango_ot_info_get_gsub () from /usr/lib/libpangoft2-1.0.so.0
#5  0x005306e4 in pango_ot_info_get_gpos () from /usr/lib/libpangoft2-1.0.so.0
#6  0x00530782 in pango_ot_info_find_script ()
   from /usr/lib/libpangoft2-1.0.so.0
#7  0x008b188a in ?? () from /usr/lib/pango/1.4.0/modules/pango-arabic-fc.so
#8  0x0a5333d8 in ?? ()
#9  0x00000000 in ?? ()

Comment 1 Adam Guthrie 2006-08-01 21:14:52 UTC
So apparently there is a problem in the freetype library that's causing this
crash. It's been fixed by bug 200033. 

You should be able to download the problem by downloading the new RPM for
freetype mentioned in this advisory:
http://rhn.redhat.com/errata/RHBA-2006-0613.html.

Comment 2 jmccann 2006-08-01 23:44:56 UTC
Yup, that fixes it.  I suppose this is a dup then but I'm not able to see that
bug.  And apparently I'm not allowed to close this even though I'm the reporter.

Comment 3 Ray Strode [halfline] 2006-08-03 17:00:43 UTC

*** This bug has been marked as a duplicate of 200033 ***


Note You need to log in before you can comment on or make changes to this bug.