Bug 2007834 - arb-2.22.1 is available
Summary: arb-2.22.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-25 10:03 UTC by Upstream Release Monitoring
Modified: 2022-06-16 01:20 UTC (History)
1 user (show)

Fixed In Version: arb-2.22.1-1.fc37 arb-2.22.1-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-07 17:43:10 UTC
Type: ---


Attachments (Terms of Use)
[patch] Update to 2.21.0 (#2007834) (945 bytes, patch)
2021-09-25 10:03 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 2.21.1 (#2007834) (945 bytes, patch)
2021-10-20 19:23 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.22.0 (#2007834) (945 bytes, patch)
2022-01-16 00:56 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2021-09-25 10:03:02 UTC
Latest upstream release: 2.21.0
Current version/release in rawhide: 2.20.0-3.fc36
URL: http://arblib.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/7886/

Comment 1 Upstream Release Monitoring 2021-09-25 10:03:07 UTC
Created attachment 1826151 [details]
[patch] Update to 2.21.0 (#2007834)

Comment 2 Upstream Release Monitoring 2021-09-25 10:15:51 UTC
the-new-hotness/release-monitoring.org's scratch build of arb-2.21.0-1.fc32.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=76263445

Comment 3 Jerry James 2021-09-25 14:43:07 UTC
This version removes functions used by sagemath 9.4, so we will have to wait for a sagemath version that has been updated for arb 2.21.0.

Comment 4 Upstream Release Monitoring 2021-10-20 19:23:03 UTC
Latest upstream release: 2.21.1
Current version/release in rawhide: 2.20.0-3.fc36
URL: http://arblib.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/7886/

Comment 5 Upstream Release Monitoring 2021-10-20 19:23:06 UTC
Created attachment 1835333 [details]
[patch] Update to 2.21.1 (#2007834)

Comment 6 Upstream Release Monitoring 2021-10-20 19:37:20 UTC
the-new-hotness/release-monitoring.org's scratch build of arb-2.21.1-1.fc34.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=77579282

Comment 7 Upstream Release Monitoring 2022-01-16 00:56:29 UTC
Latest upstream release: 2.22.0
Current version/release in rawhide: 2.20.0-3.fc36
URL: http://arblib.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/7886/

Comment 8 Upstream Release Monitoring 2022-01-16 00:56:33 UTC
Created attachment 1851077 [details]
Update to 2.22.0 (#2007834)

Comment 9 Upstream Release Monitoring 2022-01-16 01:09:35 UTC
the-new-hotness/release-monitoring.org's scratch build of arb-2.22.0-1.fc34.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=81295860

Comment 10 Upstream Release Monitoring 2022-01-25 15:23:49 UTC
Latest upstream release: 2.22.1
Current version/release in rawhide: 2.20.0-3.fc36
URL: http://arblib.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/7886/

Comment 11 Upstream Release Monitoring 2022-01-25 15:23:52 UTC
Scratch build failed. Details bellow:

GenericError: File upload failed: cli-build/1643124231.223494.xgwOqzDI/arb-2.22.1-1.fc34.src.rpm
Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.9/site-packages/koji/__init__.py", line 3000, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.9/site-packages/koji/__init__.py", line 2935, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 12 Fedora Update System 2022-06-07 17:38:48 UTC
FEDORA-2022-3193745ede has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-3193745ede

Comment 13 Fedora Update System 2022-06-07 17:43:10 UTC
FEDORA-2022-3193745ede has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2022-06-07 21:39:56 UTC
FEDORA-2022-0326bd55bf has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-0326bd55bf

Comment 15 Fedora Update System 2022-06-08 01:14:20 UTC
FEDORA-2022-0326bd55bf has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-0326bd55bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0326bd55bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2022-06-16 01:20:26 UTC
FEDORA-2022-0326bd55bf has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.