Bug 2008120 - Regression: core container io performance metrics are missing for pod, qos, and system slices on nodes
Summary: Regression: core container io performance metrics are missing for pod, qos, a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.9
Hardware: All
OS: All
high
urgent
Target Milestone: ---
: 4.9.z
Assignee: Philip Gough
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 2007677
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-27 10:50 UTC by Philip Gough
Modified: 2021-10-26 17:22 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2007677
Environment:
Last Closed: 2021-10-26 17:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1404 0 None open Bug 2008120: Adjust dropped cAdvisor metrics 2021-10-15 18:04:53 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:22:57 UTC

Comment 1 Junqi Zhao 2021-09-30 09:52:30 UTC
tested with the PR, search metrics from prometheus with

count(container_fs_writes_total) by (id)
count(container_blkio_device_usage_total) by (id)
could see the metrics with id

{id="/"}
{id="/system.slice"}
{id="/system.slice/crio.service"}
{id="/kubepods.slice"}
{id="/kubepods.slice/kubepods-besteffort.slice"}
note: if you want to see result for "{id="/kubepods.slice/kubepods-besteffort.slice"}", make sure you have qosClass: BestEffort running pods

# oc -n openshift-monitoring get servicemonitor kubelet -oyaml
...
    metricRelabelings:
    - action: drop
      regex: container_(network_tcp_usage_total|network_udp_usage_total|tasks_state|cpu_load_average_10s)
      sourceLabels:
      - __name__
    - action: drop
      regex: (container_spec_.*|container_file_descriptors|container_sockets|container_threads_max|container_threads|container_start_time_seconds|container_last_seen);;
      sourceLabels:
      - __name__
      - pod
      - namespace
    - action: drop
      regex: (container_blkio_device_usage_total);.+
      sourceLabels:
      - __name__
      - container
    - action: drop
      regex: container_memory_failures_total
      sourceLabels:
      - __name__
    - action: drop
      regex: (container_fs_.*);.+
      sourceLabels:
      - __name__
      - container

Comment 7 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935


Note You need to log in before you can comment on or make changes to this bug.