Bug 2008142 - [4.9.z backport] [OCP 4.9] Backport Allow web terminal to be installed in any namespace
Summary: [4.9.z backport] [OCP 4.9] Backport Allow web terminal to be installed in any...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.0
Assignee: Josh Pinkney
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 2006329
Blocks: 2008141
TreeView+ depends on / blocked
 
Reported: 2021-09-27 12:18 UTC by Josh Pinkney
Modified: 2022-02-16 13:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: if you install the web terminal operator on an OpenShift cluster the terminal icon on the banner head will only appear if the web terminal operator is installed in the OpenShift-Operators namespace. In order to support fully support OSD (and devsandbox), we needed the ability to have the devworkspacetemplates and the web terminal operator to be installed in other namespaces then openshift-operators and have those devworkspacetemplates still be picked up by the console. Consequence: Operator couldn't be installed in namespace other than openshift-operators Result: devworkspacetemplates are installed in the namespace where the operator is installed.
Clone Of:
Environment:
Last Closed: 2021-11-29 10:53:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 596 0 None open (4.9 Backport) Bug 2008142: Change web terminal subscription permissions from get to list 2021-09-27 12:34:14 UTC
Github openshift console pull 10135 0 None open (4.9 Backport) Bug 2008142: Allow web terminal to be installed in any namespace 2021-09-27 12:34:13 UTC
Red Hat Product Errata RHBA-2021:4834 0 None None None 2021-11-29 10:54:14 UTC

Description Josh Pinkney 2021-09-27 12:18:06 UTC
Description of problem:
The "Allow web terminal to be installed in any namespace" pull request on GitHub must backported to OpenShift 4.9. This will allow Web Terminals to be installed in any namespace which is a requirement for OSD.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 6 spathak@redhat.com 2021-11-25 20:00:41 UTC
Verified on build version: 4.9.0-0.nightly-2021-11-22-062405
Browser version: chrome 90

Comment 8 errata-xmlrpc 2021-11-29 10:53:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.9 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4834


Note You need to log in before you can comment on or make changes to this bug.