Bug 2008266 - Update to kubernetes patch version 1.19.14
Summary: Update to kubernetes patch version 1.19.14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Mike Dame
QA Contact: Ke Wang
URL:
Whiteboard:
: 1965972 (view as bug list)
Depends On: 2003027
Blocks: 2004836
TreeView+ depends on / blocked
 
Reported: 2021-09-27 18:11 UTC by Mike Dame
Modified: 2022-01-17 14:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
This fix contains the following changes coming from updated version of kubernetes up to v1.19.14: Changelog for v1.19.14: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11913 Changelog for v1.19.13: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11912 Changelog for v1.19.12: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11911 Changelog for v1.19.11: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11910 Changelog for v1.19.10: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1199 Changelog for v1.19.9: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1198 Changelog for v1.19.8: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1197 Changelog for v1.19.7: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1196 Changelog for v1.19.6: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1195 Changelog for v1.19.5: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1194
Clone Of: 2003027
Environment:
Last Closed: 2021-10-20 14:29:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 1012 0 None Merged [release-4.6] Bug 2008266: bump(k8s): to 1.19.14 2021-10-07 13:12:03 UTC
Github openshift apiserver-library-go pull 63 0 None Merged [release-4.6] Bug 2008266: bump(k8s): to 1.19.14 2021-10-07 13:12:05 UTC
Github openshift client-go pull 196 0 None Merged [release-4.6] Bug 2008266: bump(k8s): to 1.19.14 2021-10-07 13:12:06 UTC
Github openshift kubernetes pull 962 0 None open [release-4.6] Bug 2008266: Rebase 1.19.14 2021-10-07 13:12:06 UTC
Github openshift library-go pull 1214 0 None Merged [release-4.6] Bug 2008266: bump(k8s): to 1.19.14 2021-10-07 13:12:07 UTC
Red Hat Product Errata RHBA-2021:3829 0 None None None 2021-10-20 14:29:17 UTC

Description Mike Dame 2021-09-27 18:11:43 UTC
+++ This bug was initially created as a clone of Bug #2003027 +++

This fix contains the following changes coming from updated version of kubernetes up to v1.19.14:

Changelog for v1.19.5: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1194
Changelog for v1.19.6: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1195
Changelog for v1.19.7: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1196
Changelog for v1.19.8: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1197
Changelog for v1.19.9: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1198
Changelog for v1.19.10: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v1199
Changelog for v1.19.11: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11910
Changelog for v1.19.12: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11911
Changelog for v1.19.13: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11912
Changelog for v1.19.14: https://github.com/kubernetes/kubernetes/blob/release-1.19/CHANGELOG/CHANGELOG-1.19.md#changelog-since-v11913

Comment 3 Ke Wang 2021-10-08 04:20:30 UTC
The changes listed in above have many upstream changes across different teams/components, not only kube-apiserver. For the functional/upgrade tests on the new version's changes, they are ensured being covered by whole QE subteams z-stream regression E2E and upgrade tests before the release (and they file/track bugs there if hitting bugs WRT the rebase). Given that and check the kube-apiserver version of 4.6 latest payload as below, to deal with this, marking Status as VERIFIED directly.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-10-08-000856   True        False         17m     Cluster version is 4.6.0-0.nightly-2021-10-08-000856

$ oc describe co/kube-apiserver | grep -A6 'Versions:'
  Versions:
    Name:     raw-internal
    Version:  4.6.0-0.nightly-2021-10-08-000856
    Name:     kube-apiserver
    Version:  1.19.14
    Name:     operator
    Version:  4.6.0-0.nightly-2021-10-08-000856

Comment 6 errata-xmlrpc 2021-10-20 14:29:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.48 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3829

Comment 7 Scott Dodson 2022-01-17 14:57:24 UTC
*** Bug 1965972 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.