Bug 200863 - RFE: Can we include SuSe's slab patches to desktop/panel to support recently-used-applications?
RFE: Can we include SuSe's slab patches to desktop/panel to support recently-...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-07-31 20:56 EDT by Chris Chabot
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 14:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2006-07-31 20:56:51 EDT
I'm currently working on packaging the Slab menu from suse (WIP at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=199681) for fedora extras.

One of its 'nifty' functionalities is 'Recently used applications'.

To enable this functionality, they have developed 2 patches against gnome
desktop, and gnome panel.

Both patches can be viewed here:
http://cvs.gnome.org/viewcvs/slab/patch/

I was wondering if they could be included in fedora's gnome-{desktop,panel}
packages so we can offer this functionality too.

I do know their not the smalest of patches, and are relatively intrusive .. but
if i don't try there's no chance of succeeding right? :-)
Comment 1 Ray Strode [halfline] 2006-08-01 09:20:16 EDT
It might be hard given that test2 is already frozen.  I'll add it to the Target
tracker though and we'll see what happens.
Comment 2 Matthias Clasen 2006-08-01 13:01:41 EDT
I'd like to see this functionality upstream first.
Comment 3 Rahul Sundaram 2006-08-01 13:09:32 EDT
Upstream is probably not going to happen anytime soon. Only the slab menu uses
this particular recently used apps feature. Not the regular gnome menus.  The 
current Fedora slab package in review has already patched it out and replaced it
with "places" since the recently menu feature depends on panel patches too. We
would achieve feature parity by doing this and monitor progress of upstream. 

This does mean deviating a bit from our policy of staying close to upstream but
we have made exceptions. Prominently Xen in FC6. 
Comment 4 Chris Chabot 2006-08-01 16:21:44 EDT
There is a good case to be made from the usability perspective, something slab
has been made for ..

Favorites are apps you never want to forget how to get too, and recent are apps
you use a lot .. from their 'better desktop' video's this seems to work very
well in practise, so it is a great boost to the usability aspect of slab to have
this functionality
Comment 5 Matthias Clasen 2006-08-01 23:41:03 EDT
> Only the slab menu uses this particular recently used apps feature.

Sounds like a great argument to wait for upstream to vet these patches.
Comment 6 Rahul Sundaram 2006-08-02 10:58:48 EDT
Yes, upstream probably can vet these patches and that might even be you but the
question is just whether we are willing to carry these patches for a release or
two meanwhile for us to provide the slab menu functionality properly. If not
please close this request. Thanks. 
Comment 7 Ray Strode [halfline] 2007-03-28 14:47:44 EDT
well we missed the fc6 and fc7 feature freezes for this.  I think I agree with
Matthias.  We should get the patches upstream.  is there an upstream report?

Note You need to log in before you can comment on or make changes to this bug.