Bug 2008645 - Screensharing doesnt work in Firefox (sway)
Summary: Screensharing doesnt work in Firefox (sway)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-desktop-portal-wlr
Version: 35
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Aleksei Bavshin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-28 18:56 UTC by Dandim
Modified: 2021-11-14 03:43 UTC (History)
7 users (show)

Fixed In Version: wireplumber-0.4.4-2.fc35 xdg-desktop-portal-wlr-0.5.0-1.fc35 xdg-desktop-portal-wlr-0.5.0-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-04 07:31:24 UTC
Type: Bug


Attachments (Terms of Use)
log (5.10 KB, application/octet-stream)
2021-09-28 18:56 UTC, Dandim
no flags Details

Description Dandim 2021-09-28 18:56:08 UTC
Created attachment 1827147 [details]
log

Created attachment 1827147 [details]
log

Description of problem:
Screensharing doesnt work in Firefox after upgrade to Fedora 35 Beta

Version-Release number of selected component (if applicable):


How reproducible:
Upgrade F34 -> F35
Everything works except screensharing in Firefox 

Steps to Reproduce:
1.
2.
3.

Actual results:
Screensharing doesnt work

Expected results:
Screensharing works

Additional info:
DE: Sway/Wayland
Steps to fix it:
Switch back to pipewire-media-session:
sudo dnf swap wireplumber pipewire-media-session

Comment 1 Fedora Update System 2021-10-15 14:49:43 UTC
FEDORA-2021-3c4c454c98 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3c4c454c98

Comment 2 Fedora Update System 2021-10-15 20:51:54 UTC
FEDORA-2021-3c4c454c98 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3c4c454c98`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3c4c454c98

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Geraldo Simião 2021-10-16 18:22:11 UTC
Have you tested with any other browser? Are you shure this is wireplumber problem?

I'm using here:
wireplumber-0.4.3-2.fc35.x86_64
wireplumber-libs-0.4.3-2.fc35.x86_64
and firefox shares screen normaly, at plasma-wayland (it's F35 kde)on firefox using jitsi meeting

Yesterday I have a problem with firefox and jitsi, but the origin was with an older version of mozilla-openh264 and openh264. today I updated to
openh264-2.1.1-3.fc35.x86_64
mozilla-openh264-2.1.1-3.fc35.x86_64
gstreamer1-plugin-openh264-1.19.1-1.fc35.x86_64
and all is fine. Have tested normal meeting and screen sharing and all worked fine.

Operating System: Fedora Linux 35
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.12-300.fc35.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-3632QM CPU @ 2.20GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4000

firefox-93.0-2.fc35.x86_64

Comment 4 Geraldo Simião 2021-10-16 18:23:56 UTC
ohhh, sorry, I just saw now you submited a log from pipewire error

Comment 5 Fedora Update System 2021-10-24 20:21:14 UTC
FEDORA-2021-3c4c454c98 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3c4c454c98

Comment 6 Fedora Update System 2021-10-28 18:27:25 UTC
FEDORA-2021-3c4c454c98 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Dandim 2021-10-29 21:46:30 UTC
Hi,
sorry but the problem still persist.
I install the fresh desktop with fresh installation of Fedora 35 beta and the problem is the same. I cannot share the screen with Wireplumber.

Comment 8 Dandim 2021-10-31 08:27:23 UTC
I found the upstream new opened bug:
https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/87

Comment 9 Dandim 2021-11-03 18:48:49 UTC
From discussion on the bug its looks like that bug is on another project: https://github.com/emersion/xdg-desktop-portal-wlr/issues/168
And the bug was fixed in master. That mean we should move this bug into another package.

Comment 10 Fedora Update System 2021-11-03 20:33:50 UTC
FEDORA-2021-d0a047047c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d0a047047c

Comment 11 Fedora Update System 2021-11-03 20:46:40 UTC
FEDORA-2021-1941faed04 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1941faed04

Comment 12 Dandim 2021-11-04 07:30:40 UTC
The bug was fixed by update of package. Thank you for very quick fix. :-)

Comment 13 Fedora Update System 2021-11-04 14:08:55 UTC
FEDORA-2021-d0a047047c has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d0a047047c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d0a047047c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-11-04 14:14:00 UTC
FEDORA-2021-1941faed04 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1941faed04`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1941faed04

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2021-11-05 16:10:36 UTC
FEDORA-2021-d0a047047c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d0a047047c

Comment 16 Fedora Update System 2021-11-05 16:26:47 UTC
FEDORA-2021-1941faed04 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-1941faed04

Comment 17 Fedora Update System 2021-11-06 01:11:56 UTC
FEDORA-2021-d0a047047c has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d0a047047c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d0a047047c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2021-11-06 02:35:22 UTC
FEDORA-2021-1941faed04 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-1941faed04`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-1941faed04

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2021-11-10 02:54:29 UTC
FEDORA-2021-d0a047047c has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2021-11-14 03:43:16 UTC
FEDORA-2021-1941faed04 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.