Bug 200867 - Sporadic x11 crash
Sporadic x11 crash
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 00:39 EDT by Jonathan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-01 17:46:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from after crash. (41.59 KB, text/plain)
2006-08-01 00:41 EDT, Jonathan
no flags Details

  None (edit)
Description Jonathan 2006-08-01 00:39:41 EDT
Description of problem:

X11 stops and am dumped back to the console with a backtrace like 

Backtrace:
0: X(xf86SigHandler+0xa8) [0x10083978]
1: [0x100374]
2: X(miComputeCompositeRegion+0x984) [0x10121dd4]
3: /usr/lib/xorg/modules/libfb.so(fbComposite+0x310) [0xea91a50]
4: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x1ac) [0xea2433c]
5: X [0x1013b604]
6: X(CompositePicture+0xfc) [0x101240fc]
7: X(miGlyphs+0x258) [0x101201f8]
8: /usr/lib/xorg/modules/libxaa.so(XAAGlyphs+0x220) [0xea22eb0]
9: X [0x1013b2b4]
10: X(CompositeGlyphs+0xcc) [0x1012421c]
11: X [0x1012c2c8]
12: X [0x10127c48]
13: X(Dispatch+0x238) [0x10045b08]
14: X(main+0x480) [0x10027260]
15: /lib/libc.so.6 [0xf51d540]
16: /lib/libc.so.6(__libc_start_main+0x144) [0xf51d764]

Fatal server error:
Caught signal 11.  Server aborting

 or

Backtrace:
0: X(xf86SigHandler+0xa8) [0x10083978]
1: [0x100374]
2: [(nil)]
3: /usr/lib/xorg/modules/libfb.so(fbComposite+0x310) [0xea91a50]
4: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x1ac) [0xea2433c]
5: X [0x1013b604]
6: X(CompositePicture+0xfc) [0x101240fc]
7: X(miTrapezoids+0x274) [0x10123194]
8: X(CompositeTrapezoids+0xbc) [0x101243dc]
9: X [0x1012cf6c]
10: X [0x10127c48]
11: X(Dispatch+0x238) [0x10045b08]
12: X(main+0x480) [0x10027260]
13: /lib/libc.so.6 [0xf51d540]
14: /lib/libc.so.6(__libc_start_main+0x144) [0xf51d764]

Fatal server error:
Caught signal 11.  Server aborting


It is not apparent to me as to what action is causing this - initially it
happened when moving the mouse over the kde panel, it has also happened while
scrolling pages in Firefox.

Bug has only occured since yum update, today.


Version-Release number of selected component (if applicable):

xorg-x11-drv-nv-1.2.0-3 was installed today.


How reproducible:

The more things going on on the screen, the more likely it is to happen.


Steps to Reproduce:

Make the screen busy.  And wait for an inconvenient moment.


Additional info:

Hardware info :
$ cat /proc/cpuinfo
processor       : 0
cpu             : PPC970FX, altivec supported
clock           : 900.000000MHz
revision        : 3.0 (pvr 003c 0300)

timebase        : 33333333
platform        : PowerMac
machine         : PowerMac8,1
motherboard     : PowerMac8,1 MacRISC4 Power Macintosh
detected as     : 338 (iMac G5)
pmac flags      : 00000000
L2 cache        : 512K unified
pmac-generation : NewWorld

$ /sbin/lspci
f0:0b.0 Host bridge: Apple Computer Inc. U3L AGP Bridge
f0:10.0 VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go5200]
(rev a1)
0001:00:01.0 PCI bridge: Apple Computer Inc. Shasta PCI Bridge
0001:00:02.0 PCI bridge: Apple Computer Inc. Shasta PCI Bridge
0001:00:03.0 PCI bridge: Apple Computer Inc. Shasta PCI Bridge
0001:01:07.0 Class ff00: Apple Computer Inc. Shasta Mac I/O
0001:01:0b.0 USB Controller: NEC Corporation USB (rev 43)
0001:01:0b.1 USB Controller: NEC Corporation USB (rev 43)
0001:01:0b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0001:02:0c.0 IDE interface: Broadcom K2 SATA
0001:02:0d.0 Class ff00: Apple Computer Inc. Shasta IDE
0001:02:0e.0 FireWire (IEEE 1394): Apple Computer Inc. Shasta Firewire
0001:03:0f.0 Ethernet controller: Apple Computer Inc. Shasta (Sun GEM)

Full Xorg.log attached.
Comment 1 Jonathan 2006-08-01 00:41:58 EDT
Created attachment 133368 [details]
Log from after crash.
Comment 2 Matěj Cepl 2006-12-22 10:22:36 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachment using the bugzilla file attachment
link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

You may also consider upgrade to FC6
(http://fedoraproject.org/wiki/Distribution), many issues found in the previous
distributions were fixed there.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Jonathan 2007-02-25 19:53:39 EST
Have changed to a different distro and have not experienced the same problem.  I
can provide no further information.  Please close as appropriate.

Note You need to log in before you can comment on or make changes to this bug.