Bug 200869 - gethostbyname_r() call takes more time in RHEL 3 than Red Hat 7.2
Summary: gethostbyname_r() call takes more time in RHEL 3 than Red Hat 7.2
Status: CLOSED DUPLICATE of bug 200870
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc   
(Show other bugs)
Version: 3.0
Hardware: i586 Linux
medium
urgent
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-01 06:17 UTC by Yi Tao
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 16:11:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yi Tao 2006-08-01 06:17:00 UTC
Description of problem:

A measure of the time taken to call gethostbyname_r() turns out that this API 
takes significantly more time to return than Red Hat 7.2.

Also the recent upgrade from Red Hat 7.2 to RHEL 3 turns out that, the time 
taken by gethostbyname_r() is not as stable/consistently low as previously in 
Red Hat 7.2.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get system time before calling gethostbyname_r();
2. Call gethostbyname_r();
3. Get system time after calling gethostbyname_r();
4. The time taken by gethostbyname_r() is the difference between system times 
of step 3 and step 1.

It is expected to call multiple domain names under both RHEL 3 and Red Hat 7.2

Actual results:
It takes longer time on RHEL3 than on Red Hat 7.2. Also the time used by 
gethostbyname_r() for different domain names on RHEL3 are more diverse than on 
Red Hat 7.2

Expected results:
RHEL3 should be consistently low as, and even lower than Red Hat 7.2 

Additional info:

Comment 1 Ulrich Drepper 2006-08-01 16:11:57 UTC

*** This bug has been marked as a duplicate of 200870 ***


Note You need to log in before you can comment on or make changes to this bug.