Bug 200872 - cman can't cope with more than 31 nodes
cman can't cope with more than 31 nodes
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 02:37 EDT by Christine Caulfield
Modified: 2009-04-16 16:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 11:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2006-08-01 02:37:30 EDT
Description of problem:


A couple of people on the list have seen this. cman seems to be quite happy ina
cluster of 31 nodes, but adding the 32nd causes it all to fall apart. 

According to the one detailed log I have seen, the transition master node first
falls out wih "Inconsistent cluster view". After that, the other nodes all leave
with "No response to messages".

I have not reproduced this yet (slight lack of real nodes) but I'm going to have
a good try using virtualisation.
Comment 4 Christine Caulfield 2006-10-25 09:29:22 EDT
Just fot the record we (well kevin) have managed to get 39 Xen nodes running
quite happily. So it appears there is no hard limit here at least.
Comment 5 Kiersten (Kerri) Anderson 2007-01-04 12:09:12 EST
We haven't been able to recreate this problem on the latest code base and the
number of machines available at the time.  We have run 39 virtual nodes in a
cluster, so need help in recreating it.  Marking the bugzilla as needinfo for now.
Comment 6 Christine Caulfield 2008-03-11 11:26:07 EDT
Marking this WONTFIX. Customers who need more than 31 nodes should use gulm or
RHEL5.

Note You need to log in before you can comment on or make changes to this bug.