Bug 200879 - Signal related defect in pdksh-5.2.14-30.3
Signal related defect in pdksh-5.2.14-30.3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pdksh (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks: FAST4.5APPROVED
  Show dependency treegraph
 
Reported: 2006-08-01 04:24 EDT by Karsten Hopp
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 10:55:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-08-01 04:24:29 EDT
Description of problem:
'trap exit 1 ERR' fails with  ksh: trap: bad signal ERR

Version-Release number of selected component (if applicable):
pdksh-5.2.14-30.3

Additional info:
the sort parameters in siglist.sh work only for some of the signals, result is
that some signals are not sorted in the output.
sed -n 's/{ QwErTy/{/p' < $out | awk '{print NR, $0}' | sort -b -k3.3n -k 1n ...
needs to be replaced with
sed -n 's/{ QwErTy/{/p' < $out | awk '{print NR, $0}' | sort -k3n -k 1n ...
Comment 4 Matthew Roth 2006-09-20 15:25:06 EDT
I was not able to reproduce this problem in pdksh-5.2.14-30.3 on RHEL 4 Update 
3, but I do encounter this problem in pdksh-5.2.14-21.5 on RHEL 3 Update 8.  
pdksh-5.2.14-21 worked fine but then when Update 8 was applied that include 
pdksh-5.2.14-21.5 I get this error.

When will there be an update to fix pdksh-5.2.14-21.5 on RHEL 3?
Comment 5 Karsten Hopp 2006-09-28 07:47:04 EDT
re comment #4: You need to file a new bugzilla against RHEL-3. 
In the meantime try this unofficial, unsupported package:
http://people.redhat.com/karsten/pdksh-5.2.14-21.7.i386.rpm
Comment 9 Karel Volný 2007-06-27 10:55:39 EDT
this bug depends on the build environment, if systemv-style or gnu-style 
parameters are used

none of the examined packages for pdksh-5.2.14-30.3 suffers from it, so 
closing

Note You need to log in before you can comment on or make changes to this bug.