Bug 2008846 - [Doc] Migration plan is failing for VM with no OS in an unclear way
Summary: [Doc] Migration plan is failing for VM with no OS in an unclear way
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Migration Toolkit for Virtualization
Classification: Red Hat
Component: Documentation
Version: 2.2.0
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: ---
: 2.2.0
Assignee: Sasha Beskin
QA Contact: kpunwatk
Avital Pinnick
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-29 10:33 UTC by kpunwatk
Modified: 2021-12-12 08:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-12-12 08:59:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
v2v-virt log (65.62 KB, text/plain)
2021-09-29 10:33 UTC, kpunwatk
no flags Details
Screenshot (76.29 KB, image/png)
2021-09-29 10:34 UTC, kpunwatk
no flags Details
forklift-controller log (7.38 MB, text/plain)
2021-09-29 10:48 UTC, kpunwatk
no flags Details

Description kpunwatk 2021-09-29 10:33:39 UTC
Created attachment 1827275 [details]
v2v-virt log

Description of problem:
With MTV-2.2 Migration Plan for specific VM's from the RHV Source Provider are failing with the Error-Convert image to kubevirt. Please find the attachment Screenshot, v2v-virt log, Forklift-controller log are attached.

Version-Release number of selected component (if applicable):
MTV-2.2.0-20/CNV-4.9.0-192/OCP-4.9

Steps to Reproduce:
1.In MTV create a Plan with any one of the specific VMs rhel7-karishma, rhel8-karishma, rhv-vm-test, v2v-rhel8-auto, istein-cirros, karishma-test-mig.
2.Start the Plan.

Expected results: Migration plan should end successfully


Additional info: 
On MTV-2.2.0-1/CNV-4.9.0-192/OCP-4.9 they were migrated successfully.
RHV Provider: rhev-blue-01.rdu2.scalelab.redhat.com

Comment 1 kpunwatk 2021-09-29 10:34:56 UTC
Created attachment 1827276 [details]
Screenshot

Comment 2 kpunwatk 2021-09-29 10:48:52 UTC
Created attachment 1827280 [details]
forklift-controller log

Comment 3 kpunwatk 2021-10-01 08:27:20 UTC
Verified on  MTV-2.2.0-20/CNV-4.9.0-192. Tested the Rhel7/Rhel8 VMs having bootable disks and they succeeded at the guest conversion step.
Migration Plan completed Successfully.

Comment 4 Ilanit Stein 2021-10-11 09:26:56 UTC
Apparently this bug was reported for VMs that had no actual OS installed.

Comment 5 Ilanit Stein 2021-10-11 09:32:08 UTC
Fabien Dupont:

"The problem is that we only know that the virt-v2v pod exited with a non zero return code. We don't have the error message.
We could probably parse the pod logs to identify the error, but I'm not even sure that it will be that explicit.
IMO, this is a corner case and we could simply put a note in the docs."

Comment 6 Avital Pinnick 2021-10-14 13:01:17 UTC
This should be included in the release notes as a known issue.

Comment 7 Sasha Beskin 2021-12-09 16:21:30 UTC
Included in MTV 2.2 release notes
PR:
https://github.com/konveyor/forklift-documentation/pull/241
Ready for QE

Comment 8 Ilanit Stein 2021-12-09 16:42:10 UTC
PR content looks good to me. Moving bug to VERIFIED.

Comment 9 Avital Pinnick 2021-12-12 08:59:45 UTC
Changes merged


Note You need to log in before you can comment on or make changes to this bug.