Bug 200887 - /usr/share/java/libgcj-4.1.1.jar multilib conflict
/usr/share/java/libgcj-4.1.1.jar multilib conflict
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 07:59 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.1-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 03:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2006-08-01 07:59:49 EDT
Description of problem:

I cannot install both the i386 and x86_64 version of libgcj, because they
contain different versions of: /usr/share/java/libgcj-4.1.1.jar


p.s.

You're probably already aware through the mailinglist but I thought I should BZ
it for tracking.
Comment 1 Jakub Jelinek 2006-08-07 07:23:27 EDT
libgcj-4.1.1.jar doesn't have a multilib conflict, only libgcj-tools-4.1.1.jar
does:

for i in */libgcj-*4.1.1-14.*.rpm; do rpm -qp --qf
'[%{FILENAMES}\t%{ARCH}\t%{FILEMD5S}\n]' $i 2>/dev/null | fgrep .jar; done |
LC_ALL=C sort -u
/usr/share/java/libgcj-4.1.1.jar        i386    1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-4.1.1.jar        ia64    1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-4.1.1.jar        ppc     1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-4.1.1.jar        ppc64   1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-4.1.1.jar        s390    1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-4.1.1.jar        s390x   1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-4.1.1.jar        x86_64  1a6f5780b01c818f324a95970be1a406
/usr/share/java/libgcj-tools-4.1.1.jar  i386    4247bc93a54a29d43b0fc36b6debbfa0
/usr/share/java/libgcj-tools-4.1.1.jar  ia64    17ad1b0656942cbd19f44b4dd4b9891d
/usr/share/java/libgcj-tools-4.1.1.jar  ppc     5b96c815561c7dba0e63c7c9025b7b7b
/usr/share/java/libgcj-tools-4.1.1.jar  ppc64   188f2b38d3f6ee93853dfb5e95b25bd8
/usr/share/java/libgcj-tools-4.1.1.jar  s390    4effbcaab415422648d85a6e41203483
/usr/share/java/libgcj-tools-4.1.1.jar  s390x   79b6de494ea1cd83d15c5fce992f9f39
/usr/share/java/libgcj-tools-4.1.1.jar  x86_64  b3fda335822d8e4710b0125814a1ed8c
Comment 2 Hans de Goede 2006-08-09 08:13:37 EDT
My mistake, the effect is the same though.
Comment 3 Hans de Goede 2006-08-14 11:13:58 EDT
If I read yesterdays RawHide logs correctly this is fixed now, so this should be
closed I think. Not closing myself because I haven't verified the fix.
Comment 4 Jakub Jelinek 2006-08-17 03:21:33 EDT
It wasn't really fixed in 4.1.1-16 still, but it is in 4.1.1-17.

Note You need to log in before you can comment on or make changes to this bug.