Bug 200888 - GIMP doesn't handle spaces in files correctly.
GIMP doesn't handle spaces in files correctly.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 08:18 EDT by Armijn Hemel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-15 11:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 347544 None None None Never

  None (edit)
Description Armijn Hemel 2006-08-01 08:18:38 EDT
Description of problem:

GIMP doesn't handle spaces in files correctly. When I open an image, that has
spaces in its filename and then resave it, GIMP will replace it with %20. The
file ends up with %20 in its filename on disk. So, before it is written to disk
the %20 is not translated to a space.

Version-Release number of selected component (if applicable):
gimp-2.2.12-1.fc5

How reproducible:

Always

Steps to Reproduce:
1. open an image, save it to a file with spaces in its name
2. reopen the image, save it again. All spaces in the name will be replaced by %20
  
Actual results:

filename changed, spaces were replaced by %20

Expected results:

I would have expected that the spaces would be left intact.

Additional info:
Comment 1 Armijn Hemel 2006-08-01 10:18:59 EDT
It seems to be a known bug in GIMP: http://bugzilla.gnome.org/show_bug.cgi?id=347544
Comment 2 Nils Philippsen 2006-08-02 10:47:20 EDT
gimp-2.2.12-3 which includes the upstream fix are building right now for Rawhide
and FC-5.
Comment 3 Fedora Update System 2006-08-04 13:47:15 EDT
gimp-2.2.12-3.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Armijn Hemel 2006-08-15 11:10:59 EDT
Everything works ok now, so I guess this report can be closed.

Note You need to log in before you can comment on or make changes to this bug.