Bug 2008912 - glib2-devel installation error: file /usr/share/glib-2.0/codegen/__pycache__/codegen_docbook.cpython-310.pyc conflicts between attempted installs of glib2-devel-2.70.0-3.fc35.i686 and glib2-devel-2.70.0-3.fc35.x86_64
Summary: glib2-devel installation error: file /usr/share/glib-2.0/codegen/__pycache__/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glib2
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
: 2008836 (view as bug list)
Depends On:
Blocks: F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-09-29 13:32 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2021-10-15 17:58 UTC (History)
15 users (show)

Fixed In Version: glib2-2.70.0-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-07 23:31:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2021-09-29 13:32:43 UTC
Description of problem:
$ sudo dnf upgrade
...

Error: Transaction test error:
  file /usr/share/glib-2.0/codegen/__pycache__/codegen_docbook.cpython-310.opt-1.pyc conflicts between attempted installs of glib2-devel-2.70.0-3.fc35.i686 and glib2-devel-2.70.0-3.fc35.x86_64
  file /usr/share/glib-2.0/codegen/__pycache__/codegen_docbook.cpython-310.pyc conflicts between attempted installs of glib2-devel-2.70.0-3.fc35.i686 and glib2-devel-2.70.0-3.fc35.x86_64

I'll mark this as high-severity because this breaks updates, and in the transaction test phase which is particularly nasty.

Comment 1 Richard W.M. Jones 2021-09-30 08:16:25 UTC
Can confirm this is happening here too and prevents me
testing a 32 bit qemu:

Error: Transaction test error:
  file /usr/share/glib-2.0/codegen/__pycache__/codegen_docbook.cpython-310.opt-1.pyc from install of glib2-devel-2.70.0-3.fc36.i686 conflicts with file from package glib2-devel-2.70.0-3.fc36.x86_64
  file /usr/share/glib-2.0/codegen/__pycache__/codegen_docbook.cpython-310.pyc from install of glib2-devel-2.70.0-3.fc36.i686 conflicts with file from package glib2-devel-2.70.0-3.fc36.x86_64

Comment 2 Patrick Griffis 2021-09-30 14:53:12 UTC
The fix is probably the same as this older fix[0] except with the new files:

[0] https://src.fedoraproject.org/rpms/glib2/c/dea8a050ccfc2eeece476b52000469627ae8b6f7?branch=master

Comment 3 Fedora Blocker Bugs Application 2021-10-05 08:45:27 UTC
Proposed as a Blocker for 35-final by Fedora user zbyszek using the blocker tracking app because:

 Break upgrades, violating:
> For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed.

Comment 4 Michael Catanzaro 2021-10-05 18:24:11 UTC
(In reply to Patrick Griffis from comment #2)
> The fix is probably the same as this older fix[0] except with the new files:
> 
> [0]
> https://src.fedoraproject.org/rpms/glib2/c/
> dea8a050ccfc2eeece476b52000469627ae8b6f7?branch=master

Unfortunately no, the current spec file does:

touch -r gio/gdbus-2.0/codegen/config.py.in %{buildroot}%{_datadir}/glib-2.0/codegen/*.py

which should cover all new files in this directory. I'm not sure what is wrong.

Hi Miro, can I ask if this issue looks familiar to you? It seems the pyc files are no longer reproducible across architectures.

I was also going to CC: Zbigniew since you worked on this in bug #1686078 and I figured you might have some ideas... but it seems you are the reporter here. :P

Comment 5 Miro Hrončok 2021-10-05 20:29:03 UTC
> It seems the pyc files are no longer reproducible across architectures.

They have never been reproducible. The pyc files generated on any architecture are compatible with each other, but they are not guaranteed to be bit by bit identical. In order to achieve that, you should use the procedure described in https://docs.fedoraproject.org/en-US/packaging-guidelines/Python_Appendix/#_byte_compilation_reproducibility

I can prep a pull request.

Comment 6 Miro Hrončok 2021-10-05 20:44:31 UTC
https://src.fedoraproject.org/rpms/glib2/pull-request/11 should fix this, but please verify or wait for my verification.

Comment 7 Fedora Update System 2021-10-05 21:55:35 UTC
FEDORA-2021-832f38ba20 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-832f38ba20

Comment 8 Michael Catanzaro 2021-10-05 22:00:03 UTC
(In reply to Fedora Update System from comment #7)
> FEDORA-2021-832f38ba20 has been submitted as an update to Fedora 35.
> https://bodhi.fedoraproject.org/updates/FEDORA-2021-832f38ba20

Zbigniew, please double-check it. Pretty sure it will be good, but never hurts to check.

Thanks again, Miro!

Comment 9 Zbigniew Jędrzejewski-Szmek 2021-10-06 06:31:54 UTC
Thanks, seems to work fine. I gave karma.

Comment 10 Adam Williamson 2021-10-06 17:44:15 UTC
-5 blocker / +5 Fe in https://pagure.io/fedora-qa/blocker-review/issue/497 , rejecting as a blocker but accepting as FE.

Comment 11 Fedora Update System 2021-10-07 23:31:50 UTC
FEDORA-2021-832f38ba20 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Michael Catanzaro 2021-10-15 17:58:37 UTC
*** Bug 2008836 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.